Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 24084 - RFE: Allow booting from CDROM read KS file from NFS
RFE: Allow booting from CDROM read KS file from NFS
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-15 21:19 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 15:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-15 21:19:01 EST
Kickstart NFS:

linux ks=nfs:server:/path/to/ks.cfg

does not work when booting from the CDROM.  I had to use the floppy image
"bootnet.img" to get this mode to work.  Is this intentional?  Why is
this?  Surely there is enough room on the CD-ROM to include a "super
kernel" that has bootnet.img's features in it, no?
Comment 1 Michael Fulbright 2001-01-17 15:15:12 EST
We currently do not support this mechanism. I will mark this as a future feature
enhancement.

The problem is the CDROM boots from a image which is the same as the boot.img
image in the images/ directory. It does not have network devices so its can't
load the ks file at loader time.
Comment 2 Brock Organ 2001-01-17 15:17:37 EST
and additionally, brian, since we use the boot.img for booting from both cdrom
and floppy disk, the boot.img cannot exceed the size of a floppy, so we are
unable to expand the boot.img to take advantage of the space on the cd currently
... thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.