Bug 240840 - rpmlint misses to detect non-utf8/non-ascii encoded file
rpmlint misses to detect non-utf8/non-ascii encoded file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-22 05:26 EDT by Ralf Corsepius
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.81-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 13:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2007-05-22 05:26:53 EDT
Description of problem:
libexif contains a non-utf8/non-ascii encoded file
/usr/share/doc/libexif-0.6.13/README

rpmlint doesn't catch this (check the README for "Lutz". The last name after
Lutz is "Müller", but it is displayed as "M<junk>ller". The file seems to be 
iso8859-X encoded.)

# rpmlint libexif-0.6.13-2.i386.rpm 
E: libexif zero-length /usr/share/doc/libexif-0.6.13/AUTHORS

Version-Release number of selected component (if applicable):
libexif-0.6.13-2
Comment 1 Ville Skyttä 2007-05-22 11:30:54 EDT
Right, due to (probably my) thinko uncompressed doc files were not checked in
0.80 and earlier.  Fixed upstream a week ago, will be in the next release:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1343

$ rpmlint libexif
libexif.x86_64: E: zero-length /usr/share/doc/libexif-0.6.13/AUTHORS
libexif.x86_64: W: file-not-utf8 /usr/share/doc/libexif-0.6.13/ChangeLog
libexif.x86_64: W: file-not-utf8 /usr/share/doc/libexif-0.6.13/COPYING
libexif.x86_64: W: file-not-utf8 /usr/share/doc/libexif-0.6.13/README
Comment 2 Fedora Update System 2007-09-07 13:21:34 EDT
rpmlint-0.81-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.