This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 240859 - LiveCD boot failure on pata DVD-RW drive
LiveCD boot failure on pata DVD-RW drive
Status: CLOSED DUPLICATE of bug 239657
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
David Lawrence
http://smolt.fedoraproject.org/show?U...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-22 09:56 EDT by Michael Forrest
Modified: 2013-03-05 22:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 18:54:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output after attempting mount of /dev/sdc (16.39 KB, text/plain)
2007-05-22 09:56 EDT, Michael Forrest
no flags Details

  None (edit)
Description Michael Forrest 2007-05-22 09:56:03 EDT
Description of problem:
f7t4 liveCD fails to fully boot using a DVD-RW as the boot device.

After inialising a number of devices, the kernel hangs for approximately one
minute and then produces the message:

WARNING: Cannot find root file system!

and drops to a root prompt for user to contruct symlink to /dev/root.

dmesg reports finding the DVD-RW device. but when /dev/sdc is manually
created with mknod (blk dev maj:8 min:32) and then mounted with:

mount -t iso9660 /dev/sdc /mnt

the mount fails reporting:

mount: /dev/sdc is not a valid block device

after udev creates /dev/sda{1,2} and /dev/sdb{1 .. 15}. (see dmesg attqched)
there is no /dev/sdc is usable for /dev/root. 

Has DVD driver code been deliberately excluded from the f7t4 liveCD
kernel?

The LiveCD was burnt with a fully functioning and patched fc6
install - no problems with the DVD-RWdevice itself. LiveCD just
won't boot! Tt is my only way of installing (no CD drive attached
to the machine).

Version-Release number of selected component (if applicable):
f7t4 i386 LiveCD

How reproducible:
Always

Steps to Reproduce:
1. Insert LiveCD into DVD-RW (only device which can read the CD)
2. Cols boot machine.
3. vmlinuz and initrd.img loaded, but cannot find root partition.
  
Actual results:
Dumped into a shell with nothing to link /dev/root to. 

Expected results:
A fully booted LiveCD

Additional info:

My smolt output for this machine (from fc6, no hardware has changed):
http://smolt.fedoraproject.org/show?UUID=7ffea52c-f70c-4688-b162-2df17100316b

lsmod output of f7t4 kernel:
Module                  Size  Used by
ext3                  126841  1 
jbd                    61473  1 ext3
mbcache                12741  1 ext3
sd_mod                 24513  2 
ata_generic            12357  0 
ehci_hcd               36185  0 
uhci_hcd               27737  0 
pata_via               15557  1 
sata_via               15685  0 
libata                116965  3 ata_generic,pata_via,sata_via
scsi_mod              141357  2 sd_mod,libata
Comment 1 Michael Forrest 2007-05-22 09:56:03 EDT
Created attachment 155159 [details]
dmesg output after attempting mount of /dev/sdc
Comment 2 Michael Forrest 2007-05-22 10:09:39 EDT
Step to reproduce #2 was meant to be "Cold boot machine" !
Comment 3 Jeremy Katz 2007-05-22 10:30:58 EDT
If you manually load sr_mod at this point, does /dev/root exist and things then
work?
Comment 4 Michael Forrest 2007-05-22 18:47:26 EDT
Yes, if I perform:

modprobe sr_mod

the /dev/root symlink magically appears to a (newly attached) "sr0" device.

I then exit that shell and the LiveCD fully boots to a lovely hot air ballon
login screen.

Thanks very much Jeremy, you rock!
Comment 5 Jeremy Katz 2007-05-22 18:54:47 EDT

*** This bug has been marked as a duplicate of 239657 ***

Note You need to log in before you can comment on or make changes to this bug.