Bug 240892 - /dev/twe0 needs a chcon (3w_xxxx)
/dev/twe0 needs a chcon (3w_xxxx)
Status: CLOSED DUPLICATE of bug 232218
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-22 13:56 EDT by Joshua Daniel Franklin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 14:46:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua Daniel Franklin 2007-05-22 13:56:40 EDT
Description of problem:
The devices /dev/twe* (for older 3ware controllers) have the
wrong context. Similar to #232218, but in this case the
driver is 3w_xxxx and the devices are /dev/twe*.

This fixed it temporarily for me:
for i in /dev/twe*; do chcon -t fixed_disk_device_t $i; done

sealert reports this:

Summary
    SELinux is preventing /usr/sbin/smartd (fsdaemon_t) "getattr" access to
    device /dev/twe0.

Detailed Description
    SELinux has denied the /usr/sbin/smartd (fsdaemon_t) "getattr" access to
    device /dev/twe0. /dev/twe0 is mislabeled, this device has the default label
    of the /dev directory, which should not happen.




Version-Release number of selected component (if applicable):
selinux-policy-2.4.6-30.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2007-05-22 14:46:31 EDT
The same fix for 232218 fixes this problem.

*** This bug has been marked as a duplicate of 232218 ***
Comment 2 Joshua Daniel Franklin 2007-07-09 19:47:20 EDT
I'm not sure there is a fix for Bug #232218 yet, unless
you mean the updated SELinux Reference Policy:
http://oss.tresys.com/projects/refpolicy/changeset/2246
I assume you're the "Dan" mentioned in the ChangeLog.

That's only a fix for Fedora 7. Will RHEL 5.1 or another
future update include an updated SELinux Reference Policy?
Comment 3 Daniel Walsh 2007-07-11 14:05:18 EDT
Yes this should be fixed in the u1 policy.  You can grab a prerelease at
http://people.redhat.com/dwalsh/SELinux/RHEL5

Note You need to log in before you can comment on or make changes to this bug.