Bug 240907 - X only starts once or twice - V_BIOS address out of range
X only starts once or twice - V_BIOS address out of range
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-22 15:38 EDT by Ian Pilcher
Modified: 2010-09-10 11:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-10 11:56:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (2.24 KB, text/plain)
2007-05-22 15:38 EDT, Ian Pilcher
no flags Details
log of X failure to start (21.31 KB, text/plain)
2007-05-22 15:40 EDT, Ian Pilcher
no flags Details

  None (edit)
Description Ian Pilcher 2007-05-22 15:38:12 EDT
Description of problem:
Dual-head (Xinerama) config, ThinkPad T60 w/ 1680x1050 panel and external
1280x1024 LCD (analog connection).  After booting, I am able to start X once
or twice.  Eventually, I start getting this error:

    V_BIOS address 0x7d8e0 out of range

At this point, I have to reboot before I can successfully start X once or
twice.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.5-9.2.el5.x86_64

How reproducible:
100% (although sometimes X fails to start the second time, sometimes the
third)

Steps to Reproduce:
1.  Acquire appropriate hardware
2.  Use attached xorg.conf
3.  Boot to runlevel 3
4.  startx
5.  Log out of X (or ctrl-alt-backspace)
6.  Repeat steps 4 and 5 once or twice
  
Actual results:
X fails to start.

Expected results:
X should work.

Additional info:
Comment 1 Ian Pilcher 2007-05-22 15:38:12 EDT
Created attachment 155196 [details]
xorg.conf
Comment 2 Ian Pilcher 2007-05-22 15:40:40 EDT
Created attachment 155197 [details]
log of X failure to start
Comment 4 Derek Atkins 2007-09-20 17:18:12 EDT
I have this this same problem on a Thinkpad T60 running Fedora 7, running
xorg-x11-drv-i810-2.0.0-4.fc7

I have a very similar X config and very similar output/log.  I can upload mine
if you care.

I was using the "intel" driver, but it wouldn't support dual-head, so I switched
to the i810 driver and noticed this problem.

I'm running in x86-mode so the platform should get changed from x86_64 to All.
I'd also like to increase the severity because it means I cannot logout and
login as another user (without rebooting), which is a MAJOR inconvenience, but
Bugzilla wont let me. :(
I didn't change the Release/Version, even though this affects more than just RHEL5
Comment 5 Ian Pilcher 2007-09-20 18:11:21 EDT
You can work around this problem by turning DRI off -- Option "DRI" "off" in your
"Device" section(s).
Comment 6 Derek Atkins 2007-09-20 18:40:24 EDT
Unfortunately that didn't help.  In fact it made it worse -- X would "lock" in a
way that I had to use the power button instead of X failing and falling back to
text-mode.  Any other suggestions?
Comment 7 Derek Atkins 2007-12-10 13:48:58 EST
It's been almost three months with no progress on this bug.  The driver in
current Fedora 7 still doesn't let you restart X when using the i810 driver. 
I'd increase the severity but it wont let me.  This means you cannot change
users without rebooting, which makes it hard to perform certain maintenence
activities.
Comment 8 Adam Jackson 2010-09-10 11:56:29 EDT
The intel driver in current builds of RHEL5 should support this chip natively.  We have no plans to update the vesa driver to address any support issues with this chip.

Note You need to log in before you can comment on or make changes to this bug.