Bug 240932 - Network manager does not enable IPv6
Summary: Network manager does not enable IPv6
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-23 01:21 UTC by Steve Hill
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-23 10:38:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Hill 2007-05-23 01:21:43 UTC
Description of problem:
Interfaces configured by NetworkManager do not appear to have IPv6 enabled

Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. Allow Network Manager to configure an interface
2. "/sbin/ip ad" to check the addresses on the NIC
  
Actual results:
Only the IPv4 address is present.

Expected results:
IPv6 link-local addresses should be present and if there is a IPv6 router on the
network running radvd the global-scope IPv6 addresses should also be assigned.

Additional info:

Comment 1 Steve Hill 2007-06-23 10:38:47 UTC
Invalidating this bug - this was caused by a combination of the disabled ipv6
support in Fedora 7 test 3 and the iwl3945 driver being broken.


Note You need to log in before you can comment on or make changes to this bug.