Bug 240948 - Anaconda traceback during kickstart install
Anaconda traceback during kickstart install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-05-23 05:35 EDT by Roderick Johnstone
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-27 15:28:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roderick Johnstone 2007-05-23 05:35:34 EDT
Description of problem:
Running a kickstart install gives traceback from anaconda.

Version-Release number of selected component (if applicable):
Current rawhide

How reproducible:
Every time

Steps to Reproduce:
1. Run a kickstart install
2.
3.
  
Actual results:
Traceback from Anaconda, finishing with (copied by hand):

if os.environ["LANG"].find("UTF") != -1 or os.environ["LANG"].find("utf") != -1
File "/usr/lib/python2.5/UserDict.py, line 22, in __getitem__
    raise KeyError(key)
KeyError: 'LANG'

Expected results:
Rawhide is installed.

Additional info:
Kickstart file contains:
lang en_GB.UTF-8
This worked fine with the F7 test4 install.

I have also tried with:
lang en_GB
and it gives the same error.
Comment 1 Roderick Johnstone 2007-05-24 11:12:24 EDT
Still seems to fail in the same way with todays rawhide that contains
anaconda-11.2.0.63-2.i386.rpm.

Works fine if I remove the "lang" statement from the kickstart file, except that
it prompts me for the language.
Comment 2 Jeremy Katz 2007-05-24 12:59:05 EDT
This is related to the locale stuff I'm currently looking at...
Comment 3 Jeremy Katz 2007-05-24 16:34:29 EDT
Will be fixed with rhpl-208
Comment 4 Jarod Wilson 2007-05-24 18:29:46 EDT
Will try to reproduce this in the morning...
Comment 5 Will Woods 2007-05-27 15:28:24 EDT
This should be fixed in current rawhide and F7rc2. All of my kickstart-based
testing has completed successfully. Please retest and confirm. If the problem
persists, feel free to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.