Bug 240963 - Using install from hard disk method, anaconda installs when using 5 iso files as source but fails if using extracted ISOs as source
Summary: Using install from hard disk method, anaconda installs when using 5 iso files...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-23 14:30 UTC by Alex Magnay
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-24 17:01:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Magnay 2007-05-23 14:30:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; InfoPath.2; .NET CLR 1.1.4322)

Description of problem:
Using install from harddisk method. 

Kickstart documentation suggests that OS source can be an extracted directory tree of the contents of the setup ISO files.  When installing via kickstart, with source ISO files on hardisk, runs great!  When installing via kickstart with extracted iso files on harddisk it fails.

Want to be able to maintain a (replicated) Linux source directory tree on our network for OS installation containing current RPMs. Need ISOs extracted to do this.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
Using a Windows Preinstallation Environment (WinPE) initiated build
1.create 5GB fat32 partition (drive c:)
2.copy ISO files to c:\source
3.Copy ks.cfg, vmlinuz and initrd.img to c:\source\boot
4.install grub
5.reboot into linux
6.kickstart runs fine.

Do the same as above using extracted files in C:\source and kickstart fails, prompts for path to install media.

Kickstart file contains:  harddrive --dir=/source --partition=/dev/hda1
Grub menu.lst file contains: 

kernel /source/boot/vmlinuz ramdisk_size=8192 method=hd://hda1/source/ ks=hd:hda1:/source/ks.cfg

Actual Results:
Kickstarts prompts for path to images. Won't accept patch to extracted source files.

Expected Results:
Install using extracted source files (which would have current RPMs)

Additional info:
Means have to update RPMs after OS is installed. This adds significant time to build process. Also means I have to store iso images AND RPMs on local network.

Using install from harddisk method because we're not permitted DHCP and PXE on server network. Pre-assigned static IPs only.  Using WinPE to reuse inplace OS install mechanisum and software distribution solution.

Comment 1 Jeremy Katz 2007-05-24 17:01:11 UTC
Hard drive installs only support ISOs, not the exploded trees.


Note You need to log in before you can comment on or make changes to this bug.