Bug 240979 - upgrade from 1.0.10-7.fc6 to 1.0.10-10.fc6 fails
Summary: upgrade from 1.0.10-7.fc6 to 1.0.10-10.fc6 fails
Status: CLOSED DUPLICATE of bug 240225
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-23 15:10 UTC by Stepan Kasal
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 15:47:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stepan Kasal 2007-05-23 15:10:21 UTC
I have run "yum upgrade".  Among other packages, it decided to upgrade nfs-utils
from 1.0.10-7.fc6 to 1.0.10-10.fc6.
Yum installs the new rpm first and then removes the prefious one.

But nfs-utils-1.0.10-7.fc6 contains the following postun script:
if [ "$1" -ge 1 ]; then
        /etc/rc.d/init.d/rpcidmapd condrestart > /dev/null
        /etc/rc.d/init.d/rpcgssd condrestart > /dev/null
        /etc/rc.d/init.d/nfs condrestart > /dev/null
fi

Because of bug #240978 the last command failed.  Rpm, seeing that the postun
script failed, canceled the transaction, and both versions of nfs-utils package
has stayed on my computer.

I had to re-run rpm manually to get rid of the old version of nfs-utils.

Comment 1 Stepan Kasal 2007-05-23 15:47:55 UTC
The problem is masked since 1.0.10-11.fc6.

Comment 2 Stepan Kasal 2007-05-23 15:49:08 UTC

*** This bug has been marked as a duplicate of 240225 ***


Note You need to log in before you can comment on or make changes to this bug.