This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 240993 - Opening a URL from an app moves browser window to apps workspace
Opening a URL from an app moves browser window to apps workspace
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xfwm4 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-23 11:55 EDT by David Swegen
Modified: 2016-02-17 19:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-29 14:20:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Swegen 2007-05-23 11:55:59 EDT
Description of problem:

If clicking on a link in thunderbird for instance the link will be opened in
firefox. However, it also moves the browser window to the same workspace as the
app that called it.

This didn't occur in FC5, nor for a long while in FC6. For a while I was able to
fix the problem by ticking "active focus stealing prevention" in the "window
manager tweaks" settings applet. However, this no longer works.

Version-Release number of selected component (if applicable):
xfwm4-4.4.1-1.fc6

How reproducible:
Every time a link is clicked

Steps to Reproduce:
1. Open firefox
2. Go to different workspace containing app such as xchat ot thunderbird
3. Click on URL displayed in app
  
Actual results:
Link opens correctly in firefox, but browser window is moved to workspace of
calling app


Expected results:
Link should open, but browser window should not move workspace

Additional info:
Comment 1 Kevin Fenzi 2007-05-23 12:03:44 EDT
Ah yes... See: 
http://bugzilla.xfce.org/show_bug.cgi?id=2961

Basically this is fixed in 4.4.1, but with a hidden option since they didn't
want to add UI bits in a stable update. ;( 

See comment #12 in the above bug for how to set the hidden option. 
Can you try that workaround and see if it fixes things for you?
Comment 2 David Swegen 2007-05-29 05:31:25 EDT
That does indeed seemed to have fixed the problem. Thanks for that.
Comment 3 Kevin Fenzi 2007-05-29 12:12:07 EDT
Excellent. I wish there was a more transparent fix, but it looks like thats
going to be the only one until the next Xfce release when they can add that into
the UI. 
:( 

Shall we go ahead and close out this bug now?
Comment 4 David Swegen 2007-05-29 12:32:32 EDT
Yup, as far as I'm concerned that resolved the issue. Maybe put a note in a
README or something?
Comment 5 Kevin Fenzi 2007-05-29 14:20:28 EDT
I added a note to the F7 packagenotes wiki page. 
Hopefully that will get out to a wide audience... 

http://fedoraproject.org/wiki/Docs/Beats/PackageNotes

Note You need to log in before you can comment on or make changes to this bug.