Bug 241088 - Anaconda throws backtrace when installing on existing mdraid
Summary: Anaconda throws backtrace when installing on existing mdraid
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Will Woods
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-05-24 00:38 UTC by David Nielsen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 11.2.0.65-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-25 16:05:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (59.21 KB, text/plain)
2007-05-24 00:38 UTC, David Nielsen
no flags Details

Description David Nielsen 2007-05-24 00:38:16 UTC
Description of problem:
When attempting to install using the anaconda pacakge from 20070523 which
supposedly fixes this problem I still get a backtrace when installing on my
mdraid machine.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.63-2

How reproducible:
100%

Steps to Reproduce:
1. boot boot.iso
2. set http mirror
3. wait
  
Actual results:
When X comes up and you click next, anaconda elects to throw a backtrace at you

Expected results:


Additional info:

Comment 1 David Nielsen 2007-05-24 00:38:16 UTC
Created attachment 155310 [details]
anaconda dump

Comment 2 Will Woods 2007-05-24 03:19:49 UTC
Okay, so.. you've got dmraid on.. sata_nv? Can you give us a bit more info about
the RAID set up - number / type of disks, controller, etc?

Comment 3 David Nielsen 2007-05-24 04:18:46 UTC
mdraid not dmraid Woods. it's an nforce3 SATA controller with dmraid
capabilities turned off (since historically Linux has sucked on that, I plan to
change it back for F8 to break it in interesting ways). 

2 WDC WD4000YR-01P harddrives

/boot on RAID1
/, /home and SWAP on LVM on top of a RAID0

Comment 4 Will Woods 2007-05-24 04:53:29 UTC
ah, sorry.. it's late and I'm mixing up mdraid and dmraid again. 

according to pjones there was a bug in the mdraid metadata finding stuff that
should be fixed in anaconda 11.2.0.64, so hopefully the next rawhide should be
better.

Comment 5 Jarod Wilson 2007-05-24 15:03:51 UTC
I managed to pull off an mdraid upgrade yesterday without a problem, whereas I
couldn't a few days ago, so at least we're closer...

Comment 6 Jeremy Katz 2007-05-24 15:06:44 UTC
We're trying to start the device md-1 which is weird.  What's the output of
mdadm -E for /dev/sda2, /dev/sdb1 and /dev/sdb2?

Comment 7 Jarod Wilson 2007-05-24 22:24:51 UTC
Just set up a box with a pair of WD 120G ATA drives, 100M software raid1 /boot,
the rest software raid0 with lvm atop it, featuring /, /home and swap. No more
explodeyness, only oddity was grub needing to be reinstalled rather than
upgrading the existing config for some reason.

Comment 8 David Nielsen 2007-05-25 16:05:51 UTC
Works for me as of F7 RC2.


Note You need to log in before you can comment on or make changes to this bug.