Bug 241098 - No gcc-gnat for ppc64
Summary: No gcc-gnat for ppc64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords: Tracking
Depends On:
Blocks: FE-ExcludeArch-ppc64, F-ExcludeArch-ppc64 241233 254126
TreeView+ depends on / blocked
 
Reported: 2007-05-24 05:47 UTC by Orion Poplawski
Modified: 2009-01-26 08:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 08:59:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2007-05-24 05:47:12 UTC
This is to track status of gcc-gnat for ppc64 so that dependent packages can
enable support once it is completed.

Comment 1 Jakub Jelinek 2007-05-24 13:35:48 UTC
Does any package that needs Ada actually package libraries (which would need to
be multilibbed)?

Comment 2 Orion Poplawski 2007-05-24 14:28:37 UTC
plplot packages an Ada interface library and is currently a multilib package.

Comment 3 David Woodhouse 2007-05-24 15:19:16 UTC
Is this just a bootstrapping issue again (as gcc-gnat for ppc was recently) or
is there real work to be done by someone more clueful than I?

Comment 4 Jakub Jelinek 2007-05-24 15:31:19 UTC
It might be just the bootstrapping, depends on the shape of ppc64 gnat port.
I have never actually built it, so don't know its shape.

Comment 5 Orion Poplawski 2007-05-24 21:12:10 UTC
plplot is not actually shipping the ada bindings yet (just building/testing), so
this is very low priority (for plplot) at the moment.

Comment 6 Bug Zapper 2008-04-04 00:53:23 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 7 Orion Poplawski 2008-04-14 19:59:58 UTC
This is just a tracking bug.  Plplot does now have an ada interface so it would
be nice to be able to build for ppc64, but it can wait.

Comment 8 Jakub Jelinek 2009-01-26 08:59:58 UTC
gcc-4.4.0-0.9 in dist-f11-gcc44 has Ada support on ppc64.  No plans to do this for older gccs, so this will be fixed in Fedora 11.


Note You need to log in before you can comment on or make changes to this bug.