Bug 241143 - SELinux is preventing /usr/sbin/lvm (lvm_t) "write" to .cache (lvm_etc_t)
SELinux is preventing /usr/sbin/lvm (lvm_t) "write" to .cache (lvm_etc_t)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 05:49 EDT by han pingtian
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-24 10:05:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description han pingtian 2007-05-24 05:49:44 EDT
Description of problem:
When try to run the system-config-lvm, get the message from setroubleshoot:
SELinux is preventing /usr/sbin/lvm (lvm_t) "write" to .cache (lvm_etc_t)

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.6-62.fc6
system-config-lvm-1.0.18-1.2.FC6


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Additional info:
Source Context:               system_u:system_r:lvm_t:s0
Target Context:               system_u:object_r:lvm_etc_t:s0
Target Objects:               .cache [ file ]
Affected RPM Packages:
Policy RPM:                   selinux-policy-2.4.6-62.fc6
Selinux Enabled:              True
Policy Type:                  targeted
MLS Enabled:                  True
Enforcing Mode:               Enforcing
Plugin Name:                  plugins.catchall_file
Host Name:                    openfree.org
Platform:                     Linux openfree.org 2.6.20-1.2948.fc6 #1 SMP Fri Apr 2
7 19:48:40 EDT 2007 i686 i686
Alert Count:                  43
Line Numbers:

Raw Audit Messages:

avc: denied { write } for comm="lvm" dev=dm-0 egid=0 euid=0 exe="/usr/sbin/lvm" exi
t=-13 fsgid=0 fsuid=0 gid=0 items=0 name=".cache" pid=22901 scontext=system_u:syste
m_r:lvm_t:s0 sgid=0 subj=system_u:system_r:lvm_t:s0 suid=0 tclass=file tcontext=sys
tem_u:object_r:lvm_etc_t:s0 tty=pts2 uid=0
Comment 1 Daniel Walsh 2007-05-24 10:05:58 EDT
restorecon /etc/lvm/.cache

There is not much we can do to fix this in FC6.  The problem is the file gets
labeled incorrectly when you run an lvm type command that is not confined.  In
FC7 this file has been moved to /etc/lvm/cache and the file context is
maintained.  You can use restorecond and add /etc/lvm/.cache to its config file
to maintain the context.

Note You need to log in before you can comment on or make changes to this bug.