Bug 24115 - gcc 2.96-69 segfault with i686/athlon optimization
gcc 2.96-69 segfault with i686/athlon optimization
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
: 25375 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-16 10:50 EST by Daniel Karlsson
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-16 12:00:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Karlsson 2001-01-16 10:50:09 EST
--- begin test.c ---
void
func(int i)
{
  float f;

  i = 1;

  f = i ? 1 : 0;
}
--- end test.c ---

gcc -c -O[n] -march={i686|athlon} test.c
test.c: In function `func':
test.c:9: Internal error: Segmentation fault.
Comment 1 Jakub Jelinek 2001-01-16 12:00:27 EST
Fixed in CVS gcc and in my tree, the fix will appear in gcc-2.96-71.
Comment 2 Jakub Jelinek 2001-01-31 08:19:59 EST
*** Bug 25375 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.