Bug 241184 - tomcat5 fails to install due to dependency problems - jta obsoleted, need to use geronimo-jta-1.0.1B-api instead
Summary: tomcat5 fails to install due to dependency problems - jta obsoleted, need to ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Application Server
Classification: Retired
Component: tomcat5   
(Show other bugs)
Version: 2.0
Hardware: i686 Linux
urgent
urgent
Target Milestone: ---
Assignee: David Knox
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-24 12:05 UTC by Marcel Hild
Modified: 2018-10-27 12:32 UTC (History)
9 users (show)

Fixed In Version: tomcat5-5.5.23-0jpp_4rh.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 15:14:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marcel Hild 2007-05-24 12:05:34 UTC
this happens on a freshly installed rhel4 system.

[root@vpsmuc160 rhn]# up2date --show-channel
rhel-x86_64-es-4
rhel-x86_64-es-4-extras
rhel-4-es-x86_64-rhaps-2

[root@vpsmuc160 rhn]# up2date -i tomcat5

Name                                    Version        Rel     
----------------------------------------------------------
tomcat5                                 5.5.23         0jpp_4rh.3        noarch


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
tomcat5-common-lib-5.5.23-0jpp_4rh.3     requires jta >= 0:1.0.1 



Interstingly the requires and provides seem to be there, if I look in RHN. Maybe
RHN metadata is defunct.
If you install jta and then tomcat5, it works.

This is an urgent problem for one of our ISVs

Comment 1 Thomas Schweiger 2007-07-05 08:28:41 UTC
Any news on this? It's still not possible to install tomcat5 using the up2date
installation method.

Comment 2 Ben Stringer 2007-07-19 05:36:38 UTC
I am also seeing this problem. Installing jta first does not work for me as a 
work-around - up2date returns "There was a fatal RPM error. The message was: 
Failed running rpm transaction".

O/S: RHEL AS4 update 5
Java: IBM 1.4.2 SR8


Comment 3 Ben Stringer 2007-07-23 05:38:46 UTC
The dependency appears to be satisfied by installing the following package: 
 
geronimo-jta-1.0.1B-api 
 
Once this package was installed, an installation of the package "tomcat5" was 
possible. 
 
This provides me with a way forward, but still indicates a dependency error, as 
up2date should have done all of this for me. 

Comment 10 RHEL Product and Program Management 2007-11-29 04:19:49 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 16 David Walluck 2008-05-06 18:42:37 UTC
The fix has been applied, but RHAPS is in security-fix-only mode. Since this bug
is not critical, the fix will be pushed out with the next security update.


Comment 27 prem verma 2010-08-31 11:48:02 UTC
ghjghjghjghjgfhjghjgh

Comment 29 David Knox 2010-09-15 15:14:15 UTC
RHAPS tomcat5 is no longer supported. ( RHEL-4-RHAPS-V2 ). The build is currently tagged tomcat5-5.5.23-0jpp_4rh.


Note You need to log in before you can comment on or make changes to this bug.