Bug 241241 - busticated 'restart' page in webui for satellite config
Summary: busticated 'restart' page in webui for satellite config
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer   
(Show other bugs)
Version: 500
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Partha Aji
QA Contact: Preethi Thomas
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 173427
TreeView+ depends on / blocked
 
Reported: 2007-05-24 15:39 UTC by Máirín Duffy
Modified: 2007-08-06 17:02 UTC (History)
1 user (show)

Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 03:12:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
click on the restart button and then the page goes boom (122.20 KB, image/png)
2007-05-24 15:39 UTC, Máirín Duffy
no flags Details

Description Máirín Duffy 2007-05-24 15:39:19 UTC
ISO: rhn-satellite-5.0.0-32-redhat-linux-as-i386-4-embedded-oracle.iso

see before & after screenshots attached. two issues here:

(1) the satellite 'restart' page doesn't refresh after 4 minutes.
(2) the satellite 'restart' page looks bad (no css, no images)

however the Satellite does restart fine, you just have to wait the 4 minutes out
yourself and reload manually.

Comment 1 Máirín Duffy 2007-05-24 15:39:20 UTC
Created attachment 155357 [details]
click on the restart button and then the page goes boom

Comment 2 Máirín Duffy 2007-05-24 20:56:34 UTC
discovered that this happens only if monitoring is disabled in the "general" tab
of the satellite configuration web ui. as long as monitoring is disabled,
attempts to restart the satellite result in the restart screen being busticated.

if monitoring is enabled, all is well on the restart countdown screen.

Comment 3 Partha Aji 2007-05-25 16:49:40 UTC
Looks like JS was disabled .. The refresh was not happening through the meta refresh tag instead through 
some ugly java script that was deemed unnecessary... So changed the jsp to meta refresh.. This should 
work on NON-JS enabled browser now... Anyway try the fix and fail this if you still get the same error...

Comment 4 Partha Aji 2007-06-02 08:28:27 UTC
Moving to ON_QA

Comment 5 Preethi Thomas 2007-06-06 15:36:20 UTC
verified

Comment 6 Brandon Perkins 2007-06-26 03:12:48 UTC
Closed for Satellite 500 Release.


Note You need to log in before you can comment on or make changes to this bug.