Bug 241256 - Network does not work with Xen kernel
Network does not work with Xen kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 12:52 EDT by andy prowse
Modified: 2009-02-13 13:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 13:06:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andy prowse 2007-05-24 12:52:47 EDT
Description of problem:

Using the Xen kernel leaves the network unusable

Version-Release number of selected component (if applicable):

kernel 2.6.18-8.el5xen
Broadcom Netextreme BCM5751M
Fujitsu Lifebook A3040
AMD Turion 64 MObile MT-37

How reproducible:

Just boot on either 32 or 64 bit Xen kernel
(Also fails with SuSE Xen kernel)

Steps to Reproduce:
1. Boot Xen kernel
2.
3.
  
Actual results:

NO network

Expected results:

Working network

Additional info:

Same reults with both 32/64 bit Xen kernel.  Non Xen works OK.  
Tried latest Broadcom tg3 module (3.71b), same errors.
Comment 1 andy prowse 2007-06-25 15:11:16 EDT
On the kernel line for the XEN kernel, acpi=off does the trick.   I am running
XEN kernel 2.6.18-8.1.6.  I can get on the internet fine, and when the XEND
service starts toward the end of the boot, it now starts very quickly instead of
timing out and not establishing the bridge environment properly.
 
Comment 2 Bill Burns 2008-07-09 10:12:38 EDT
Have you tried it on newer RHEL kernels with out the acpi argument?
Comment 3 Bill Burns 2009-02-13 13:06:28 EST
No response to need info, closing as fixed. Please reopen if you can reproduce it on the current release. Thanks.

Note You need to log in before you can comment on or make changes to this bug.