Bug 24127 - eth-device without IP
Summary: eth-device without IP
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-16 19:19 UTC by Gerd v. Egidy
Modified: 2014-03-17 02:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-22 10:05:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch implements it (2.84 KB, patch)
2001-01-16 19:38 UTC, Gerd v. Egidy
no flags Details | Diff

Description Gerd v. Egidy 2001-01-16 19:19:18 UTC
I want to be able to create a ethernet device without assigning an IP and 
without modifying the routing table.
I need this for a eth-device connected to a DSL-modem using PPPoE.
The reason I don't want to use a fake IP is that I'm going to distribute 
this configuration and don't know if the IP / Network I've chosen is 
really bogus in the context of all users.

I've made a patch against initscripts 5.49 which adds a device without IP 
if the IPADDR var in ifcfg-ethx is empty.

Comment 1 Gerd v. Egidy 2001-01-16 19:38:58 UTC
Created attachment 7709 [details]
This patch implements it

Comment 2 Daniel Roesen 2001-01-22 10:05:01 UTC
Request seconded. I have the same situation and had to trick around, too.

Comment 3 Bill Nottingham 2001-01-29 22:40:10 UTC
A slightly different version is added in 5.60-1 - thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.