Bug 24128 - sawfish startup does not follow documentation
Summary: sawfish startup does not follow documentation
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-16 20:18 UTC by Michal Jaegermann
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-16 21:43:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-01-16 20:18:39 UTC
Sawfish documentation states (in several places) things like that:

  4. How do I add customizations?

     There are several files controlling this:

    `~/.sawfishrc'
          Hand written lisp code, loaded at startup. This is where
          almost all explicit customization should be done.

This does not correspond to reality.  Actually checking files in
/usr/share/sawfish/0.34/lisp/ one can see that only ~/.sawmillrc is
referenced in grow-pack.jl and ~/.sawmillrc actually gets loaded.
OTOH sawfish package includes a script like /usr/bin/sawmill-replace.sh

   Michal
   michal@harddata.com

Comment 1 David Mason 2001-01-16 20:27:09 UTC
I use ~/.sawfishrc  with the current build (although I think it still will
support a ~/.sawmillrc). We do ship with some default settings but all can be
nulled with information in ~/.sawfishrc

Have you tried creating one to no success?  What is the problem specifically?

Comment 2 Michal Jaegermann 2001-01-16 20:47:45 UTC
> Have you tried creating one to no success?

Well, yes, hence the bug report.

With the following line in ~/.sawfishrc

(system "xclock -padding 2 -title '' -bg lightgray -geometry 74x74+100+11 &")

nothing happens. After linking ~/.sawfishrc to ~/.sawmillrc an expected
clock face shows up.  Yes, I know that I can do that in another way on
a Gnome desktop, although not when I am running "pure sawfish"; this is
just a test example.



Comment 3 David Mason 2001-01-16 20:49:47 UTC
Thats a fine test, thanks :) Assigning.

Comment 4 Havoc Pennington 2001-01-17 00:09:16 UTC
The file lisp/sawfish/wm/user.jl loads .sawfishrc as long as no .sawmillrc
exists. Putting the xclock line in my .sawfishrc works fine for me (as long as I
have no .sawmillrc).

Comment 5 Michal Jaegermann 2001-01-17 00:46:29 UTC
Hm, interesting.  If I would have both ~/.sawmillrc and ~/.sawfishrc
then I would not notice that something does not work.  OTOH once
~/.sawmillrc was in place then now ~/.sawfishrc gets loaded as well
even if it is there only by itself.

In any case grow-pack.jl seems to reference only ~/.sawmillrc.



Note You need to log in before you can comment on or make changes to this bug.