Bug 241280 - kerning problem with Sans font and justified text alignment
Summary: kerning problem with Sans font and justified text alignment
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-24 19:24 UTC by Jared Brothers
Modified: 2018-04-11 07:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 00:04:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is html exhibiting the problem. (94 bytes, text/html)
2007-05-24 19:24 UTC, Jared Brothers
no flags Details
firefox rendering provided html (11.29 KB, image/png)
2007-05-31 13:06 UTC, Jared Brothers
no flags Details
highlighting changes placement (10.70 KB, image/png)
2007-05-31 13:07 UTC, Jared Brothers
no flags Details
more (11.30 KB, image/png)
2007-05-31 13:07 UTC, Jared Brothers
no flags Details
more (11.29 KB, image/png)
2007-05-31 13:08 UTC, Jared Brothers
no flags Details
more (11.31 KB, image/png)
2007-05-31 13:08 UTC, Jared Brothers
no flags Details
The output of fc-list (3.09 KB, text/plain)
2007-05-31 13:10 UTC, Jared Brothers
no flags Details

Description Jared Brothers 2007-05-24 19:24:50 UTC
Description of problem:
Words with "i" in them wrong kerning in the Sans font, if text is justified.

Version-Release number of selected component (if applicable):
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.3) Gecko/20070417
Fedora/2.0.0.3-4.fc7 Firefox/2.0.0.3

How reproducible:

Steps to Reproduce:
1. Open the provided html in firefox.
2. Highlight the text.
3. Unhighlight the text.

Actual results:
1. The word has improper kerning.
2. While the mouse is over selected text, the kerning of that text becomes normal.
3. The kerning returns to abnormal.

Expected results:
No characters should overlap. The text should be properly kerned.

Additional info:

Comment 1 Jared Brothers 2007-05-24 19:24:51 UTC
Created attachment 155384 [details]
Here is html exhibiting the problem.

Comment 2 Matěj Cepl 2007-05-30 23:45:51 UTC
Could you attach screenshot of the problem? It just works for me, but I don't
have to have same fonts as I have. Also could you attach please as uncompressed
attachment to this bug output of the command fc-list?

Comment 3 Jared Brothers 2007-05-31 13:06:46 UTC
Created attachment 155805 [details]
firefox rendering provided html

Comment 4 Jared Brothers 2007-05-31 13:07:32 UTC
Created attachment 155806 [details]
highlighting changes placement

Comment 5 Jared Brothers 2007-05-31 13:07:51 UTC
Created attachment 155807 [details]
more

Comment 6 Jared Brothers 2007-05-31 13:08:04 UTC
Created attachment 155808 [details]
more

Comment 7 Jared Brothers 2007-05-31 13:08:24 UTC
Created attachment 155809 [details]
more

Comment 8 Jared Brothers 2007-05-31 13:10:39 UTC
Created attachment 155810 [details]
The output of fc-list

Comment 10 Behdad Esfahbod 2007-06-01 23:46:52 UTC
This is not pango.  It's in firefox's pango backend.  I fixed it in fc6. 
Firefox 2 in f7 needs a port of my patches.  I've been supposed to fix it for
quite a while but just didn't get the time yet :(.

Comment 12 Behdad Esfahbod 2007-08-29 15:34:04 UTC
This is fixed in FC6 and F7.  Martin, can you push the pango patches into
F8/devel too?

Comment 13 Martin Stransky 2007-09-03 12:05:12 UTC
Which patch should fix that? I belive all patches from FC6 are in devel, too.

Patches in FC-6:

# font system fixes
Patch81:        firefox-1.5-nopangoxft.patch
Patch82:        firefox-1.5-pango-mathml.patch
Patch83:        firefox-1.5-pango-cursor-position.patch
Patch84:        firefox-1.5-pango-printing.patch
Patch85:        firefox-1.5-pango-cursor-position-more.patch
Patch86:        firefox-1.5-pango-justified-range.patch
Patch87:        firefox-1.5-pango-underline.patch
Patch88:        firefox-1.5-xft-rangewidth.patch

Patches in devel:

# font system fixes
Patch81:        firefox-1.5-nopangoxft.patch
Patch82:        firefox-1.5-pango-mathml.patch
Patch83:        firefox-1.5-pango-cursor-position.patch
Patch84:        firefox-2.0-pango-printing.patch
Patch85:        firefox-2.0-pango-ligatures.patch
Patch86:        firefox-1.5-pango-cursor-position-more.patch
Patch87:        firefox-1.5-pango-justified-range.patch
Patch88:        firefox-1.5-pango-underline.patch
Patch89:        firefox-1.5-xft-rangewidth.patch


Comment 14 Behdad Esfahbod 2007-09-04 00:04:10 UTC
If the patches are the same, this should be fixed already.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.