Bug 241294 - Incorrect AccessRequest for mschap and mschap-v2 protocol
Incorrect AccessRequest for mschap and mschap-v2 protocol
Status: CLOSED DUPLICATE of bug 241293
Product: Fedora
Classification: Fedora
Component: radiusclient-ng (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 17:09 EDT by Igor A Tarasov
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-24 18:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor A Tarasov 2007-05-24 17:09:24 EDT
Description of problem:
Radiusclient use incorrect AccessRequest for mschap and mschap-v2 protocol to 
authenticate against Radius Server. But old versions working fine.

Version-Release number of selected component (if applicable):
radiusclient-ng-0.5.2

How reproducible:
Cannot use MS-CHAP or MS-CHAP-V2 protocol to authenticate user. Other 
protocols (PAP and CHAP) working correct.

Steps to Reproduce:
1. Try to authenticate with ms-chap protocol
  
Actual results:
Dump of packet by freeradius:
Packet-Type = Access-Request
        Service-Type = Framed-User
        Framed-Protocol = PPP
        User-Name = "dicr"
        NAS-IP-Address = 127.0.0.1
        NAS-Port = 1
        Client-IP-Address = 127.0.0.1
This is incorrect, because there no MS-Chap-Challenge attribute for MS-CHAP 
request. 

Expected results:
Old version libradiusclient 0.3.1 work fine with the next packet dump:
Packet-Type = Access-Request
        Service-Type = Framed-User
        Framed-Protocol = PPP
        User-Name = "dicr"
        MS-CHAP-Challenge = 0x1e9cc0ca7c6a1e9e4bb40c89fc2142ff
        MS-CHAP2-Response = 
0x3d0092321c3e61197fdc418e730691cc350f0000000000000000ac9d910a28c5b9b839e9afa798919ad3b7d0be59a52e15e8
        NAS-IP-Address = 127.0.0.1
        NAS-Port = 1
        Client-IP-Address = 127.0.0.1

Additional info:
With PAP and CHAP protocol it working fine, including UserPassword or 
ChapChallenge and ChapPassword attributes, but MS-CHAP request is malformed 
and not correct. Freeradius say "No UserPassword attribute" and refuse 
authentication, but with old version libradiusclient all working fine..
Comment 1 Jeffrey C. Ollie 2007-05-24 18:27:12 EDT

*** This bug has been marked as a duplicate of 241293 ***

Note You need to log in before you can comment on or make changes to this bug.