Bug 24130 - weird menus
weird menus
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-16 15:23 EST by Michal Jaegermann
Modified: 2013-04-02 00:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-17 11:40:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-01-16 15:23:14 EST
In Gnome menu Programs->Editors submenu is empty while various editors
are scattered between Programs->Applications (like VIM) and
Programs->Utilities (like Vi IMproved).  In the past at least xemacs
used to live in Programs->Editors but now even it lost its lease.
One would expect editors find in "Editors".  Populating
/etc/X11/applink/Editors with at least links to editors in other
directories would make this a bit less funny.

BTW - the only difference between "VIM" and "Vi IMproved" seems to be
that the later attempts to edit "%f" new file - which is obviously wrong.

  Michal
  michal@harddata.com
Comment 1 David Mason 2001-01-16 15:31:36 EST
Did you perform an upgrade from a previous version? If so, which version? If you
did upgrade, had you added anything in the Editors menu yourself? The reason for
asking is that we used to have an Editors menu but we got rid of it. It should
delete the menu item but it will not if you have added something to that menu.
Comment 2 Michal Jaegermann 2001-01-16 16:00:15 EST
This was indeed an upgrade of a test installation of RH 7; and no
I did not add anything in "Editors" myself. Xemacs entry used to be
there but it moved and Editors subdirectory stuck around empty.
Trying to list with 'rpm -qf ...' an owner on any of subdirectories
in /etc/X11/applnk comes consistently "not owned by any package"
on ALL of these.

A comment really about /etc/X11/applnk/Utilities/gvim.desktop still
stands, although maybe should be filed against vim-X11-6.0-0.17
Comment 3 David Mason 2001-01-16 16:07:17 EST
OK, thanks for the feedback - we need to ensure that the menu is deleted. Assigning.
Comment 4 Michal Jaegermann 2001-01-17 11:40:04 EST
I noticed in the meantime that also emacs and xemacs when opened from a menu
with a mouse click attempt to edit a new file named '%f' like gvim from
"Utilities" (but not from "Applications").  Is this is a problem with an
expansion of empty arguments?   See also #24131.
Comment 5 Havoc Pennington 2002-03-04 12:52:30 EST
I'm not sure which of the several things mentioned here still apply - this stuff
should mostly have been cleaned up in 7.2. Reopen with specifics if some of it
wasn't.
Comment 6 Michal Jaegermann 2002-03-04 13:18:07 EST
I do not think that this applicable any longer.  Menus were reorganized
and cleaned in the meantime and pointing out that this is needed was the
crux of this bug report. :-)  Various editors now show up under
Programs->Applications.

Note You need to log in before you can comment on or make changes to this bug.