Bug 241358 - ftp install fails when trying to download rpm files, adds /%2F to the start of ftp pathname
ftp install fails when trying to download rpm files, adds /%2F to the start o...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 09:14 EDT by Alexander Boström
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 10:18:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Boström 2007-05-25 09:14:28 EDT
Description of problem:
When installing from FTP, via boot.iso, installation fails when trying to
download oprofile-gui-0.9.2-8.fc7.i386.rpm, and the path seems to be mangled.

Version-Release number of selected component (if applicable):
boot.iso with sha1sum:
55328977200b826ce8ff64c18ac2c1b120633901  boot.iso
Contents of download.fedora.redhat.com as of around Fri May 25 14:30 CEST 2007 =
Fri May 25 08:30 EDT 2007.

How reproducible:
Always.

Steps to Reproduce:
1. Boot machine (I'm using VMware Server here) on boot.iso.
2. Install in English, sv-latin1 keyboard, FTP.
3. Using server: download.fedora.redhat.com and path:
pub/fedora/linux/core/development/i386/os (note no slash before pub)
4. Deselect Office productivity, select Software development.
5. root password etc, nextnextnext...
  
Actual results:
Get dialog:
The file oprofile-gui-0.9.2-8.fc7.i386.rpm cannot be opened. This is due to a
missing file or perhaps a corrupt package. [...]

On VT 3:
WARNING : Failed to get
ftp://download.fedora.redhat.com/%2F/pub/fedora/linux/core/development/i386/os/Fedora/oprofile-gui-0.9.2-8.fc7.i386.rpm
from mirror 1/1.

Expected results:
Install without error.

Additional info:
In VMware, on IPv4 (publicly routable) and IPv6 enabled networks.
Comment 1 Alexander Boström 2007-05-25 10:12:32 EDT
HTTP install seems to work.
Comment 2 David Cantrell 2007-07-26 10:18:58 EDT
FTP installs are working fine in rawhide.  Just tested using your reproducer. 
In urlinstall.py, we have this code:

        if scheme == "ftp" and path and path.startswith("//"):
            path = "/%2F" + path[1:]

So the %2F element is added only if your path starts with two slashes.  We have
to add that for escaping in the FTP protocol.

Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.