Bug 241374 - BuildRequires libXmu-devel bzip2-devel ncurses-devel
BuildRequires libXmu-devel bzip2-devel ncurses-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 11:17 EDT by Chris Schanzle
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.5.0-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 11:55:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Schanzle 2007-05-25 11:17:59 EDT
I built R-2.5.0-2.fc6.src.rpm using chrooted mock and compared the --requires
for a "native" (sorry if that's the wrong term...I just ran 'rpmbuild -bb' on a
well-installed system). I noticed these dependency differences:

$ diff r.native r.mock
7d6
< libbz2.so.1  
27d25
< libncurses.so.5  
36a35
> libtermcap.so.2  
39d37
< libXmu.so.6  

The R documentation in doc/html/R-admin.html states that libbz2 is optional and
will use it's own copy if the system one is not found.  Since the %configure
macro includes --with-system-bzlib, I believe that is the intention, and
bzip2-libs should be included as a BuildRequires.

LibXmu is also documented as optional and if found, will use X's clipboard
functionality.

Libtermcap was discussed in bug 231195 for R-2.4.1-4.fc7 and should be
deprecated in favor of ncurses.

I suggest ammending BuildRequires as follows:

BuildRequires: libXmu-devel, bzip2-devel, ncurses-devel

I verified the --requires are now identical in the mock build with the native build.

[rpmlint also complained about %configure, %makeinstall macros used in changelog
entries, near the bottom.  Perhaps another bugreport is preferable, but if
you're there editing the spec...]
Comment 1 Tom "spot" Callaway 2007-05-25 12:00:28 EDT
Thanks for the bug report!

I've made the BR corrections to the FC-5, FC-6, and F-7 branches of R (along
with the easy changelog fixes).

F-7 already had the ncurses-devel as a BR, but now all the current Fedora
versions do.

Unfortunately, its too late for this fix to make it into F-7 final, but it will
go out as a 0day update.
Comment 2 Fedora Update System 2007-06-08 11:55:52 EDT
R-2.5.0-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.