This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 241378 - Split nas daemon and libs
Split nas daemon and libs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nas (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Frank Büttner
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F7Update
  Show dependency treegraph
 
Reported: 2007-05-25 11:33 EDT by Bastien Nocera
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-23 13:33:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-05-25 11:33:19 EDT
1. Install anything that depends on artsc
2. See nas starting up during init

You should split the libraries and the daemon, most people don't want the daemon
at all.
Comment 1 Frank Büttner 2007-06-23 11:50:42 EDT
Without the daemon it is useless, because it is needed for example for sound
output of Qt.
Comment 2 Bastien Nocera 2007-06-23 12:49:58 EDT
If I were to use Amarok, why exactly would I need nas running?
esound has the same problem (you can't use the API without the daemon running),
but we don't require the daemon to be installed, and started up on each boot
like nas does.

I want amarok installed, I don't want the daemon being started up on each boot.
Comment 3 Frank Büttner 2007-06-23 13:10:45 EDT
It is your problem, because all ports between 49152 are 65535 are usable for
all. So it is not an Bug. You have to options. Change the port of amarok or
disable the nasd via "chkconfig --level 123456 nasd off"
Comment 4 Bastien Nocera 2007-06-23 13:30:53 EDT
I still don't want nas running just because I happened to have a library that
depends on it. Please, again, split the daemon and the libraries, or I'll get
the library to drop dependency on nas' libs.
Comment 5 Frank Büttner 2007-06-23 13:33:58 EDT
No. I don't  do this, because it is not needed!!!
Comment 6 Matthias Clasen 2007-06-24 17:56:25 EDT
Bastien, 

yum remove amarok 

seems the way to go then.

Note You need to log in before you can comment on or make changes to this bug.