Bug 241381 - kernel-xen-2.6.20 won't power off on shutdown
kernel-xen-2.6.20 won't power off on shutdown
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks: 248569
  Show dependency treegraph
 
Reported: 2007-05-25 11:52 EDT by Jeff Layton
Modified: 2014-06-18 03:36 EDT (History)
9 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 19:14:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2007-05-25 11:52:50 EDT
When I was using kernel-xen-2.6.19-1.2911.6.5.fc6, on shutdown my machine would
power itself off. With kernel-xen-2.6.20-1.2952.fc6, however, on shutdown I just
get this on the serial console:

md: stopping all md devices.

Synchronizing SCSI cache for disk sda: 

System halted.

(XEN) Domain 0 halted: halting machine.


and the machine doesn't power itself off. "normal" kernel-2.6.20-1.2952.fc6
powers itself off without issue, however.

Have the ACPI defaults changed or something such that I need a different kernel
parameter, or is this a bug?

Both kernels are i686 variants. Some info about the machine:

$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 35
model name      : AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
stepping        : 2
cpu MHz         : 2210.218
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush
mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm
cmp_legacy ts fid vid ttp
bogomips        : 5527.67
clflush size    : 64

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 35
model name      : AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
stepping        : 2
cpu MHz         : 2210.218
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush
mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up pni lahf_lm
cmp_legacy ts fid vid ttp
bogomips        : 5527.67
clflush size    : 64

...

$ lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:06.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 04)
01:06.1 Input device controller: Creative Labs SB Live! Game Port (rev 01)
01:08.0 Mass storage controller: Silicon Image, Inc. SiI 3114
[SATALink/SATARaid] Serial ATA Controller (rev 02)
01:09.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 80)
05:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GT] (rev a1)

...

I can collect and post other info on request.
Comment 1 Richard W.M. Jones 2007-05-29 08:45:01 EDT
I can confirm the same here.  The machine is a 4 core AMD Athlon.  With the
latest F7 kernel it powers off.  With the latest F7 Xen kernel it stops at:

  Halting system...
  md: stopping all md devices.
  Synchronizing SCSI cache for disk sda:
  System halted.

but does not actually power off.

$ uname -a
Linux lambda 2.6.20-2925.9.fc7xen #1 SMP Tue May 22 09:29:36 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux

$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2220
stepping        : 3
cpu MHz         : 2814.480
cache size      : 1024 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush
mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni cx16
lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 7037.63
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2220
stepping        : 3
cpu MHz         : 2814.480
cache size      : 1024 KB
physical id     : 1
siblings        : 1
core id         : 0
cpu cores       : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush
mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni cx16
lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 7037.63
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

processor       : 2
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2220
stepping        : 3
cpu MHz         : 2814.480
cache size      : 1024 KB
physical id     : 2
siblings        : 1
core id         : 0
cpu cores       : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush
mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni cx16
lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 7037.63
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

processor       : 3
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2220
stepping        : 3
cpu MHz         : 2814.480
cache size      : 1024 KB
physical id     : 3
siblings        : 1
core id         : 0
cpu cores       : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush
mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni cx16
lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 7037.63
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

Other data available on request.
Comment 2 Jeff Layton 2007-05-29 21:33:34 EDT
Ran across this patch this evening. Not sure if it's applicable here, but it's
worth investigating:

http://lists.xensource.com/archives/html/xen-changelog/2007-05/msg00110.html
Comment 3 Richard W.M. Jones 2007-05-30 06:21:42 EDT
I don't think that patch can be relevant here because my reading of it is that
it's a patch to the firmware used by HVM guests.  My understanding is that this
is either a Linux (dom0) kernel or hypervisor problem.

(Unfortunately also that patch doesn't apply directly to the Xen RPM I'm using
-- it seems to depend on earlier patches to the file tools/ioemu/hw/piix4acpi.c.
 However if you'd like me to try and resolve that then let me know).
Comment 4 Jeff Layton 2007-05-30 06:49:01 EDT
Ahh, you're quite correct. I didn't look at it closely, just saw "broken ACPI"
and posted it here as a note to investigate later. Still though, it seems like
dom0 doesn't notice that it can do ACPI poweroff, so it just halts w/o trying.
So it does seem like maybe there's something wrong with how ACPI probing is working.
Comment 5 Michael Carney 2007-06-28 09:20:14 EDT
FWIW, I'm experiencing the same problem on dom0 with 2.6.20-2925.11.fc7xen. My
machine is a Dell Workstation 530, with dual 2GHz hyperthreaded Xeons w/ 1GB ram.

vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) CPU 2.00GHz
stepping        : 7
cpu MHz         : 1993.939
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush
dts acpi mmx fxsr sse sse2 ss ht tm pbe up cid xtpr
bogomips        : 4989.83
clflush size    : 64
Comment 6 Deependra Singh Shekhawat 2007-06-28 21:15:47 EDT
I am having the same problem in Fedora7. I have intel Centrino Duo Laptop.
Manufacturer Lenovo Model 3000N100.

Here are the version of packages I am using at the moment.

[root@localhost ~]# rpm -q kernel-xen
kernel-xen-2.6.20-2925.11.fc7

[root@localhost ~]# rpm -q xen
xen-3.1.0-2.fc7

And here is more information about my CPU.

[root@localhost ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 14
model name      : Genuine Intel(R) CPU           T2300  @ 1.66GHz
stepping        : 8
cpu MHz         : 1000.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc pni monitor vmx
est tm2 xtpr
bogomips        : 3328.38
clflush size    : 64

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 14
model name      : Genuine Intel(R) CPU           T2300  @ 1.66GHz
stepping        : 8
cpu MHz         : 1000.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc pni monitor vmx
est tm2 xtpr
bogomips        : 3325.08
clflush size    : 64

The system just stays on "System Halted" message after the shut down is complete
and it never actually shut down.

Today I ran into a very serious case too. I shutted down the laptop running the
Xen kernel and before it completely switched off I switched off the power and
went outside. But due to this problem it never actually powered off and it
consumed my whole battery. When I came back I saw my battery was exhausted and
later to my guess I found that my battery actually died. But that's a different
case. The battery was pretty old and maybe that's the reason why it died. 

But now I got a replacement battery and if any other information is needed I
would be eager to share here.

Thanks 

Comment 7 Thomas Antony 2007-07-09 15:39:32 EDT
I'm running F7 on two computer with different hardware and on both the xen
kernel doesn't shut down and will stay forever at system halted.
One of those is a Dell PowerEdge 2950 with Intel Xeon 5335 Quad Core, Intel, 8GB
FB RAM, PERC 5/i Controller, Intel 5000er Chipset,
The other one is my workstation with a AMD 3500+, 1GB RAM, Nvidia NForce4 Ultra
Chipset.
Comment 8 Eduardo Habkost 2007-07-09 17:10:08 EDT
The problem is more simple than I expected.

CONFIG_PM is not enabled on the more recent FC6 and F7 kernels, because of 
changes on drivers/acpi/Kconfig on the xen patch. I will make changes to 
enable it again.
Comment 9 Eduardo Habkost 2007-07-17 11:35:30 EDT
Cloned as bug #248569 for Fedora 7.
Comment 10 Red Hat Bugzilla 2007-07-24 21:41:45 EDT
change QA contact
Comment 11 Eduardo Habkost 2007-07-31 10:07:34 EDT
Fix committed to CVS, revision 1.2998.

kernel-xen-2.6-2.6.20-1.2999.fc6 submitted for pushing to updates-testing.

Note You need to log in before you can comment on or make changes to this bug.