Bug 241388 - Unneeded smartd-conf.py[co] installed in /usr/sbin
Summary: Unneeded smartd-conf.py[co] installed in /usr/sbin
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: smartmontools   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Smetana
QA Contact:
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-25 16:17 UTC by Ville Skyttä
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 5.37-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 16:40:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't include byte-compiled /usr/sbin/smartd-conf.py[co] (1.01 KB, patch)
2007-05-25 16:17 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2007-05-25 16:17:58 UTC
smartmontools installs *.pyc and *.pyo files in /usr/sbin, they're not needed
for an executable script; they're just created by brp-python-bytecompile due to
bug 182498.

Workaround attached - the "touch" part is not needed in usual Fedora build
configurations but will make the package compile on setups where automatic
python byte compilation doesn't occur.

Comment 1 Ville Skyttä 2007-05-25 16:17:58 UTC
Created attachment 155463 [details]
Don't include byte-compiled /usr/sbin/smartd-conf.py[co]

Comment 2 Tomas Smetana 2007-05-28 07:12:38 UTC
You're right. Thanks for the patch.

Comment 3 Fedora Update System 2007-06-18 16:40:12 UTC
smartmontools-5.37-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.