Bug 241390 - pirut gives stack trace when behind network proxy
Summary: pirut gives stack trace when behind network proxy
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-25 16:40 UTC by Danny Padwa
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-29 18:49:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace from pirut (1.68 KB, text/plain)
2007-05-25 16:40 UTC, Danny Padwa
no flags Details

Description Danny Padwa 2007-05-25 16:40:00 UTC
Description of problem:
On a fresh install of Fedora, there is no (obvious) way to get pirut to work 
from behind a network proxy.   All simple paths lead to Python stack traces 
instead

Version-Release number of selected component (if applicable):
Fedora 7, test 4

How reproducible:
Extremely

Steps to Reproduce:
1.  Install Fedora (fresh from the ISO) on a machine behind a proxy
2.  Login as a regular user
3.  Run Applications/'Add/Remove Software' from the menus
4.  Watch the python stack trace
5.  Say "hmmm...must not have my proxy info".   Enter it from the menus
6.  Retry running
7.  Ooh...another stack trace.
8.  Conclude that the privileged software update apps don't honor the end-user 
preferences for network proxies
9.  Realize there is no GUI to set those preferences for root
  
Actual results:
Python stack traces.   Get same from "System Tools/Software Updater"

Expected results:
System updates and new software

Additional info:
Why are we giving stack traces instead of an error message that would let the 
user enter proxy information?

Comment 1 Danny Padwa 2007-05-25 16:40:00 UTC
Created attachment 155464 [details]
Stack trace from pirut

Comment 2 Danny Padwa 2007-05-25 16:43:08 UTC
Manually adding a proxy=... line to /etc/yum.conf is the workaround to "make 
things work", but really doesn't excuse a stack trace instead of an error 
message with a dialog to fix the problem

Comment 3 Jeremy Katz 2007-05-29 18:16:45 UTC
This should be handled properly with yum 3.2.0 -- can you try and see if that helps?

Comment 4 Danny Padwa 2007-05-29 18:17:35 UTC
Will do

Comment 5 Danny Padwa 2007-05-29 18:31:53 UTC
It helps, but incompletely.

With yum 3.2 (yum-3.2.0-1.fc7) you get a semi-friendly error message ("Unable 
to retrieve software information"  Unable to retrieve software information.  
This could be caused by not having a network connection available.   There is a 
details pull down which just says "None").   But you still get no indication of 
how to fix it.  Clicking OK in this dialog closes the app, instead of leaving 
you in a state where you can update your settings

Comment 6 Jeremy Katz 2007-05-29 18:49:14 UTC
Yep, that's (unfortunately) the way we can handle things right now.  Hopefully
some of the infrastructure around PolicyKit and the like will start to make it
easier to do even more.  

And fwiw, the end-user preferences should now be honored in F7, but require a
log-out and relogin to fully take effect

Comment 7 Danny Padwa 2007-05-29 18:50:16 UTC
Fair 'nuff.   Thanks for looking into it


Note You need to log in before you can comment on or make changes to this bug.