Bug 241405 - sata_sil not loaded and raid not detected
Summary: sata_sil not loaded and raid not detected
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 7
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-25 20:01 UTC by Maurice Pijpers
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-09-16 15:45:48 UTC


Attachments (Terms of Use)
Output of lspci (1.51 KB, text/plain)
2007-05-25 20:01 UTC, Maurice Pijpers
no flags Details
output from dmesg (46.84 KB, text/plain)
2007-05-25 20:02 UTC, Maurice Pijpers
no flags Details

Description Maurice Pijpers 2007-05-25 20:01:25 UTC
Since kernel 2.6.21-1.3163 the sil raid is not detected anymore an /dev/mapper
shows no sil entry anymore.

How reproducible:
Always

Steps to Reproduce:
1. Install f7 from rawhide
2. Installers detects raid correctly
3. restart after installation
4. Unable to find raid
  
Actual results:
No entry in /dev/mapper and sata_sil is not loaded


Expected results:
2 entries in /dev/mapper and sata_sil is loaded


Additional info: I'm running a GA-M57SLI-S4 MB with 2 drives in RAID0 (created
with FC6). The drives have been detected correctly with f7t4 but have been
broken since updating to kernel 2.6.21-1.3163. Last version tried 2.6.21-1.3190.
Same problem after reinstalling from rawhide.

Comment 1 Maurice Pijpers 2007-05-25 20:01:25 UTC
Created attachment 155478 [details]
Output of lspci

Comment 2 Maurice Pijpers 2007-05-25 20:02:10 UTC
Created attachment 155479 [details]
output from dmesg

Comment 3 Bill Nottingham 2007-05-25 20:14:57 UTC
Your lspci output implies you don't actually have a sata_sil adapter.

Comment 4 Maurice Pijpers 2007-05-26 13:32:34 UTC
You are correct, the GA-M57SLI-S4 has an sata_nv adapter. The Raid was created
on another MB with sata_sil adapter. I recreated the RAID today and it now show
up as /dev/mapper/nvidia_xxxxxxx in anaconda, but problems remains the same...
After installation the Raid is not detected. Anaconda also reports: 
/dev/sdc: "sil" and "nvidia" formats discovered (using nvidia)! 
and the same for the other raid drive (/dev/sdf).

Comment 5 Maurice Pijpers 2007-05-26 17:13:34 UTC
It seems to be an anaconda problem. When formatting the raid drive with anaconda
the system will not start after reboot because the raid drive cannot be mounted.
The systems goes to the repair filesystem shell after checking the filesystems
and following message:
/data: UNEXPECTED INCONSISTENCY; run fsck MANUALLY
fsck reports that the filesystem has not been unmounted cleanly. No other errors
are found but the filesytem is modified. But this still doesn't mount the raid
on startup. After the system is started I changed the following line in /etc/fstab: 
LABEL=/data      /data        ext3      defaults   1 2
/dev/mapper/nvidia_xxxxx   /data       ext3      defaults    0 0
This will make sure the raid is mounted correctly at boot time.
Any ideas ???

Comment 6 Maurice Pijpers 2007-06-25 17:54:13 UTC
Problems still occurs in kernel-2.6.21-1.3228.fc7 but raid was correctly
detected in kernel-2.6.21-1.3194.fc7.

Comment 7 Christopher Brown 2007-09-13 18:39:51 UTC
Hello Maurice,

I'm reviewing this bug as part of the kernel bug triage project.

http://fedoraproject.org/wiki/KernelBugTriage

Are you still experiencing this problem? If not, then you may wish to close this
bug. Otherwise, could you please test with the latest kernel or even Fedora 8
Test 2, available from:

http://fedoraproject.org/wiki/Distribution/Download

Cheers
Chris



Comment 8 Maurice Pijpers 2007-09-16 15:45:48 UTC
Fedora 8 Test 2 doesn' t work for me. I am unable to install it. However problem
is solved in the current Rawhide version (16-09-2007). Closing this.


Note You need to log in before you can comment on or make changes to this bug.