Bug 241408 - utrace breaks PTRACE_SYSEMU: orig_eax value not preserved
utrace breaks PTRACE_SYSEMU: orig_eax value not preserved
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 16:18 EDT by Roland McGrath
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.21-1.2962.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-22 17:41:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case (1.55 KB, text/plain)
2007-05-25 16:18 EDT, Roland McGrath
no flags Details
refined test case (1.63 KB, text/x-csrc)
2007-05-25 21:27 EDT, Roland McGrath
no flags Details

  None (edit)
Description Roland McGrath 2007-05-25 16:18:06 EDT
PTRACE_SYSEMU behavior changed, regression affects UML.

Correct output:

-bash-3.1$ ./ptrace-sysemu 
Status 0x857f eip 8048518 eax -38 orig_eax 20
Status 0xb7f eip 8048518 eax -38 orig_eax -1
PTRACE_GETREGS: No such process
-bash-3.1$ 

Wrong output:

-bash-3.1$ ./ptrace-sysemu 
Status 0x857f eip 8048518 eax -38 orig_eax -1
Status 0xb7f eip 8048518 eax -38 orig_eax -1
PTRACE_GETREGS: No such process
-bash-3.1$
Comment 1 Roland McGrath 2007-05-25 16:18:07 EDT
Created attachment 155480 [details]
test case
Comment 2 Roland McGrath 2007-05-25 18:28:47 EDT
I have a fix in upstream utrace now.
Comment 3 Roland McGrath 2007-05-25 21:27:52 EDT
Created attachment 155493 [details]
refined test case

Expected output now looks like this:

Status 0x857f eip 8048518 eax -38 orig_eax 20
Status 0xb7f eip 8048519 eax -38 orig_eax -1
PTRACE_GETREGS: No such process
Comment 4 Chuck Ebbert 2007-06-22 17:27:54 EDT
Roland, can we close this? (the Jun 14th utrace went into FC6 kernel 2962)
Comment 5 Roland McGrath 2007-06-22 17:41:44 EDT
Yup, it's all good now.  Please close with the right number in currentrelease if
it is pushed.

Note You need to log in before you can comment on or make changes to this bug.