Bug 241432 - AVC denied regarding saslauthd during sending e-mail
Summary: AVC denied regarding saslauthd during sending e-mail
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 241484 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-25 22:35 UTC by Robert Scheck
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 14:15:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant part from audit log (5.06 KB, text/plain)
2007-05-25 22:36 UTC, Robert Scheck
no flags Details

Description Robert Scheck 2007-05-25 22:35:23 UTC
Description of problem:
See attached file.

Version-Release number of selected component (if applicable):
selinux-policy-2.6.4-8
selinux-policy-targeted-2.6.4-8

How reproducible:
Everytime when sending an e-mail.

Actual results:
AVC denied messages.

Expected results:
No AVC denied messages...

Comment 1 Robert Scheck 2007-05-25 22:36:25 UTC
Created attachment 155482 [details]
Relevant part from audit log

Comment 2 Daniel Walsh 2007-05-29 14:38:23 UTC
Fixed in selinux-policy-2.6.4-10

Comment 3 Daniel Walsh 2007-05-29 14:40:43 UTC
*** Bug 241484 has been marked as a duplicate of this bug. ***

Comment 4 Robert Scheck 2007-06-10 21:59:29 UTC
DANIEL! This bug is NOT fixed in selinux-policy-targeted-2.6.5-2:

Raw Audit Messages

avc: denied { audit_write } for comm="saslauthd" egid=0 euid=0
exe="/usr/sbin/saslauthd" exit=124 fsgid=0 fsuid=0 gid=0 items=0 pid=2362
scontext=system_u:system_r:saslauthd_t:s0 sgid=0
subj=system_u:system_r:saslauthd_t:s0 suid=0 tclass=capability
tcontext=system_u:system_r:saslauthd_t:s0 tty=(none) uid=0

avc: denied { create } for comm="saslauthd" egid=0 euid=0
exe="/usr/sbin/saslauthd" exit=8 fsgid=0 fsuid=0 gid=0 items=0 pid=2362
scontext=system_u:system_r:saslauthd_t:s0 sgid=0
subj=system_u:system_r:saslauthd_t:s0 suid=0 tclass=netlink_audit_socket
tcontext=system_u:system_r:saslauthd_t:s0 tty=(none) uid=0

avc: denied { read } for comm="saslauthd" egid=0 euid=0
exe="/usr/sbin/saslauthd" exit=36 fsgid=0 fsuid=0 gid=0 items=0 pid=2362
scontext=system_u:system_r:saslauthd_t:s0 sgid=0
subj=system_u:system_r:saslauthd_t:s0 suid=0 tclass=netlink_audit_socket
tcontext=system_u:system_r:saslauthd_t:s0 tty=(none) uid=0

Comment 5 Nils Philippsen 2007-06-11 07:24:50 UTC
Re comment #4: For me it works, I don't get denials anymore from saslauthd --
perhaps some of your files are mislabeled?

Comment 6 Robert Scheck 2007-06-11 07:30:21 UTC
The whole system is labeled correctly.

Comment 7 Daniel Walsh 2007-06-11 14:45:08 UTC
This is fixed in FC7 but not devel.

Fixed in selinux-policy-3.0.0

Comment 8 Daniel Walsh 2007-08-22 14:15:54 UTC
Should be fixed in the current release



Note You need to log in before you can comment on or make changes to this bug.