Bug 241442 - 30 second timeout when mounting smbfs filesystems
Summary: 30 second timeout when mounting smbfs filesystems
Status: CLOSED DUPLICATE of bug 168280
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Samba Maint Team
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-26 00:33 UTC by Arenas Belon, Carlo Marcelo
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 14:05:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arenas Belon, Carlo Marcelo 2007-05-26 00:33:39 UTC
Description of problem:
mounting an smbfs filesystem from a RHEL box to a RHEL box running samba, will
take 30 seconds and result in a timeout that is then recovered with a retry as
shown by :

May 25 19:41:16 sbr-qse1-3 kernel: smb_retry: no connection process
May 25 19:41:46 sbr-qse1-3 kernel: smb_add_request: request [e109de80, mid=0]
timed out!
May 25 19:41:46 sbr-qse1-3 kernel: smb_delete_inode: could not close inode 2
May 25 19:41:46 sbr-qse1-3 mount.smbfs[14519]: [2007/05/25 19:41:46, 0]
client/smbmount.c:send_fs_socket(410) 
May 25 19:41:46 sbr-qse1-3 mount.smbfs[14519]:   mount.smbfs: entering daemon
mode for service \\sbr-qse1-1.shopping.com\se, pid=14519 

Version-Release number of selected component (if applicable):
samba-client-3.0.10-1.4E.12.2

How reproducible:
always

Steps to Reproduce:
1. create an authenticated share in samba (writeable, not public)
2. mount to it
3.
  
Actual results:
# date && mount -t smbfs //sbr-qse1-1.shopping.com/se /mnt -o
username=se,password=these,uid=se,gid=se && date
Fri May 25 19:41:16 EDT 2007
Fri May 25 19:41:46 EDT 2007

Expected results:
 date && mount -t smbfs //sbr-qse1-1.shopping.com/se /mnt -o
username=se,password=these,uid=se,gid=se && date
Fri May 25 19:41:16 EDT 2007
Fri May 25 19:41:16 EDT 2007

Additional info:
the timeout happens after the smbd process is started in the server and "tconx
ok" is received by the client.

Comment 1 Arenas Belon, Carlo Marcelo 2007-05-28 08:21:56 UTC
problem goes away if using samba 3.0.25a (samba3-client) as provided from :

  ftp://ftp.sernet.de/pub/samba/rhel4-i386



Comment 2 Jatin Nansi 2007-08-03 12:24:24 UTC
This looks like a duplicate of BZ #168280.

Comment 3 Simo Sorce 2007-09-12 14:05:18 UTC

*** This bug has been marked as a duplicate of 168280 ***


Note You need to log in before you can comment on or make changes to this bug.