Bug 241459 - doesn't require pulseaudio
Summary: doesn't require pulseaudio
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: pavucontrol   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-26 02:29 UTC by Bill Nottingham
Modified: 2014-03-17 03:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 21:41:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2007-05-26 02:29:10 UTC
Description of problem:

It can't really work without the daemon present.

(Similarly for pavucontrol, pavumeter. I can file separate bugs if you want.)

Comment 1 Pierre Ossman 2007-05-26 09:08:46 UTC
Actually, they do as you can use them with a daemon on the network.

Comment 2 Bill Nottingham 2007-05-28 04:31:22 UTC
They may be able to work, but the menu entries die horribly by default.

Comment 3 Pierre Ossman 2007-05-28 17:01:29 UTC
Not sure what you mean. It's supposed to be empty until it can find a server
(through zeroconf).

Comment 4 Bill Nottingham 2007-05-29 03:27:50 UTC
Whoops, padevchooser does something reasonably OK. Fixing component.

Without pulseaudio installed,  pavumeter and pavucontrol simply pop up a:

Connection failed: Connection refused

dialog, and exit.

Comment 5 Pierre Ossman 2007-05-29 07:17:40 UTC
A bit of an upstream bug. Adding Lennart as cc since these GUI apps are his babies.

Comment 6 Lennart Poettering 2007-09-14 21:41:56 UTC
As Pierre correctly mentioned, they work fine across the network. Hence no need
for a depends line.

Nowadays the GUI tools should be showing a proper dialog bugs before they die. I
am thus closing this bug now.


Note You need to log in before you can comment on or make changes to this bug.