Bug 241461 - is in 'Office' menu
is in 'Office' menu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: genius (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 22:36 EDT by Bill Nottingham
Modified: 2014-03-16 23:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-12 09:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-05-25 22:36:58 EDT
Description of problem:

Other calculators seem to be in 'Accessories'.

Version-Release number of selected component (if applicable):

genius-0.7.7-2.fc7
Comment 1 Gérard Milmeister 2007-05-26 08:31:12 EDT
This is an upstream decision, but I agree that the "Office" category is a little
strange.
Comment 2 George Lebl 2007-10-15 14:12:16 EDT
I am willing to change this upstream to something, but I suppose it might be
better to be in the Education menu rather than the Accessories menu.  I suppose
it depends on what is your primary usage of genius. I see for example xmaxima
installs in education.  I really don't care for it being in "Education" since
that's kind of misleading.  There should really be some "Science" menu.  I
remember my original setup in the original implementation of vfolder menus had a
Science submenu.  Perhaps "Education & Science" can be used as a toplevel menu
and then query for all things that give the Science or Math or Education categories.

But it really seems like science apps are misplaced in the redhat menus.  Also I
agree that Office was a bad choice for genius.  I'll change this in svn and make
this change when 1.0.1 comes about (I just made 1.0.0 so I don't want to make a
new relase without many changes)
Comment 3 Gérard Milmeister 2007-10-15 16:33:05 EDT
There is a Science and also a Math categories. One can always include them in
the .desktop file and hope there will be sometimes a suitable menu.
Comment 4 George Lebl 2007-10-15 17:59:18 EDT
I believe I do include Science and Math.  The problem was that in some far gone
fedora, if I didn't include some other keyword the icon would not show up in the
fedora menu at all, and that's when I added Office.  Not appearing at all is
worse than appearing in a slightly wrong menu.  Hence my grip about the science
and math menu.  Perhaps badly designed toplevel menus makes developers put in
slightly bogus categories.  Hoping is crap.  For GNOME to be as usable by
non-command-line people installed software must be findable, hence appear in the
menu if I install it, I can't just hope that one day in the star trek future,
the menu will include the right submenu.

It's also annoying to find something like xmaxima in the "Education" menu, since
that's mostly wrong as well, I doubt the primary use of maxima is education. 
Macaulay2 also appears in Education which is quite bogus too.  I think I might
change Office to Education;Accessories; and let the query for the main menu do
things appropriately.
Comment 5 Gérard Milmeister 2007-10-15 19:13:03 EDT
For Maxima etc. "Development" might also be
a suitable choice.

BTW. the genius website is not accessible,
at least not to me.
Comment 6 George Lebl 2007-10-16 11:07:25 EDT
"Science & Math" or something like that, however, would be the best choice for a
menu.  I mean there are a lot of scientific/mathematics applications in fedora
and they are all pretty much misplaced or not in the menu.
Comment 7 George Lebl 2007-10-16 19:08:30 EDT
which website address are you using, http://www.jirka.org/genius.html works here.
Comment 8 Gérard Milmeister 2007-10-24 17:50:38 EDT
I am still able to access the website. However
I could retrieve the 1.0.0 tarball from the
gnome server.
Comment 9 George Lebl 2007-10-24 19:27:27 EDT
I cannot parse that last comment.  I want to fix this but I can't find the
problem.  which url in particular is having problems?
Comment 10 Gérard Milmeister 2007-10-25 12:26:02 EDT
Just now, it works, but an hour before it didn't. 
Comment 11 Bug Zapper 2008-04-03 20:57:05 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.