Bug 241477 - new code to mount VFAT by label causes erratic "duplicate label" failures
Summary: new code to mount VFAT by label causes erratic "duplicate label" failures
Status: CLOSED DUPLICATE of bug 240432
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mount   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Karel Zak
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-26 13:22 UTC by Stephan Wiesand
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 21:39:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug fix patch (325 bytes, patch)
2007-10-29 20:26 UTC, Karel Zak
no flags Details | Diff

Description Stephan Wiesand 2007-05-26 13:22:45 UTC
Description of problem:

If no label is found on a VFAT partition, the variable label is not touched at
all by the new code in mount/vfat.c. Consequently, mount thinks it has the same
label as the previous partition.

Version-Release number of selected component (if applicable):

util-linux-2.12a-16.EL4.25

How reproducible:

easily

Steps to Reproduce:
1. create two consecutive partitions
2. create an ext3 filesystem and a label on the first partition
3. create a VFAT filesystem without label on the second
4. create an fstab entry to mount the first one by label
5. mount -a
 
Actual results:

# mount -a
mount: LABEL=... duplicate - not mounted

Expected results:

this should work (and it does if one uses dosfslabel on the VFAT fs)

Additional info:

This breaks existing dual boot systems. Not uncommon.

Comment 1 Karel Zak 2007-08-20 21:39:41 UTC

*** This bug has been marked as a duplicate of 240432 ***

Comment 2 Troy Dawson 2007-10-29 19:00:25 UTC
The bug 240432 is not viewable by non-redhat employee's.
Can it be changed so it can be seen, or can the solution be posted to this bug
entry.


Comment 3 Karel Zak 2007-10-29 20:26:16 UTC
Created attachment 242391 [details]
bug fix patch


Note You need to log in before you can comment on or make changes to this bug.