Bug 241526 - atomic.h is missing in /usr/inlcude/asm
Summary: atomic.h is missing in /usr/inlcude/asm
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-27 10:03 UTC by Philippe Valembois
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-22 21:17:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Philippe Valembois 2007-05-27 10:03:20 UTC
Description of problem:
I can't compile ERESI : http://eresi.asgardlabs.org/
It requires <asm/atomic.h> which is explicitely removed during the build process
of kernel-headers package

Version-Release number of selected component (if applicable):
I know it works with FC5
All since creation kernel-headers package

How reproducible:
Always

Steps to Reproduce:
1. Compile ERESI
2.
3.
  
Actual results:
include/aproxy-machine.h:27:25: error: asm/atomic.h: No such file or directory

Expected results:
it should compile on a standard kernel tree

Additional info:
I know these headers are quite disturbing because they shouldn't be used in
userland programs but I think that if kernel.org provides it and if applications
need it, it shouldn't be removed in Fedora kernel package

Comment 1 Chuck Ebbert 2007-06-22 21:17:16 UTC
See 12.2.1 in:

http://docs.fedoraproject.org/release-notes/fc6/en_US/sn-Devel.html



Note You need to log in before you can comment on or make changes to this bug.