Bug 241537 - No printing after cups updates
Summary: No printing after cups updates
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-27 17:17 UTC by antonio montagnani
Modified: 2013-03-06 03:50 UTC (History)
2 users (show)

Fixed In Version: F-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 08:35:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error_log file for bug (1.86 MB, application/octet-stream)
2007-06-29 12:35 UTC, antonio montagnani
no flags Details

Description antonio montagnani 2007-05-27 17:17:22 UTC
Description of problem:
On any cups update, my printer stops working and I have to disinstall and
re-install it 

Version-Release number of selected component (if applicable):
any release in FC6

How reproducible:
always

Steps to Reproduce:
1.update cups
2.print a test page (nothing happens)
3.disinstall and re-install
  
Actual results:
no job printing

Expected results:
It should print after cups update

Additional info:
Using a Samsung ML-1610 laser printer with foomatic/gdi driver

Comment 1 Tim Waugh 2007-06-29 11:49:02 UTC
Please attach the /var/log/cups/error_log file after a failed print attempt
after such an upgrade.  Thanks.

Comment 2 antonio montagnani 2007-06-29 12:35:12 UTC
Created attachment 158203 [details]
Error_log file for bug

It is a part of var/log/cups/error_log file

Comment 3 antonio montagnani 2007-06-29 12:36:58 UTC
Tim,

Please note that bug is for FC6 and F7 that I am using (and it is fully updated..)

Tnx

Comment 4 Tim Waugh 2007-06-29 13:01:04 UTC
So you're still seeing the problem in F-7?

The problem seems to be that the HAL URI for the printer is not "stable" -- i.e.
it changes from time to time.

This was used for job 630 (which failed):
hal:///org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial_printer_noserial

This was used for job 631 (which succeeded):
hal:///org/freedesktop/Hal/devices/usb_device_4e8_3268_3921BRJL304582___if0_printer_noserial

So the problem is that hal is giving us inconsistent URIs for this device.

Comment 5 antonio montagnani 2007-06-29 13:08:44 UTC
Yes

still seeing in F7. I wonder why after installation of  printer, CUPS sees it
but call for the installation of another USB printer (same model, of course).
And after saying yes, now I have two twin printer (software, I mean..) also in
system-config-printer.

Really disappointing especially for newbies :-)



Comment 6 antonio montagnani 2007-06-29 13:11:36 UTC
Yes

still seeing in F7. I wonder why after installation of  printer, CUPS sees it
but call for the installation of another USB printer (same model, of course).
And after saying yes, now I have two twin printer (software, I mean..) also in
system-config-printer.

Really disappointing especially for newbies :-)



Comment 7 Tim Waugh 2007-06-29 14:15:00 UTC
Please clarify what you mean by:

"CUPS sees it but call for the installation of another USB printer"


Comment 8 antonio montagnani 2007-06-29 14:54:54 UTC
Tim

I mean that if I had already installed my printer not by CUPS but by
system-config-printer, a standard user should not see another printer ready to
be installed in CUPS. I think that something is not clear....especially for
standard users..

Comment 9 Tim Waugh 2007-06-29 15:02:23 UTC
I don't expect "newbies" to be configuring printers using the web interface in
addition to system-config-printer.  The problem you mention concerns CUPS -- if
you think it is something that needs attention, please file a separate bug
report. (FWIW, the upstream bug reporting site is http://cups.org/str.php)

Comment 10 antonio montagnani 2007-07-03 21:11:27 UTC
Tim

just updated Cups and I report that the bug seems to be solved.For the first
time I had not to disinstall and re-install my Samsung Laser printer
Tnx for help

Comment 11 Tim Waugh 2007-07-04 08:35:07 UTC
Great.  Thanks for letting me know.


Note You need to log in before you can comment on or make changes to this bug.