Bug 241551 - wqy-bitmap-fonts overrides default latin fonts
wqy-bitmap-fonts overrides default latin fonts
Status: CLOSED DUPLICATE of bug 381311
Product: Fedora
Classification: Fedora
Component: wqy-bitmap-fonts (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Qianqian Fang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-27 21:11 EDT by Kevin Kofler
Modified: 2008-01-26 06:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-26 06:56:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
experimental fontconfig file (2.06 KB, application/octet-stream)
2007-05-28 03:31 EDT, Qianqian Fang
no flags Details

  None (edit)
Description Kevin Kofler 2007-05-27 21:11:34 EDT
Description of problem:
wqy-bitmap-fonts appears to register itself as the default font for aliases 
like Sans, which means it replaces the default system font, even for latin 
characters. IMHO, that's a bad thing for a Fedora package to do. I'd even 
argue overriding the default Chinese fonts by default is a bad idea. But then 
again my opinion might not count much, because I don't speak a word of 
Chinese. ;-) (I just installed the package out of curiosity.)

Version-Release number of selected component (if applicable):
wqy-bitmap-fonts-0:0.8.1-6.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install wqy-bitmap-fonts.
2. Run any application, e.g. KCharSelect.
  
Actual results:
The menu fonts are changed.

Expected results:
The menu fonts are not affected by merely installing an additional font 
package.

Additional info:
Uninstalling the package returns the fonts to normal.
Comment 1 Qianqian Fang 2007-05-28 03:31:15 EDT
Created attachment 155532 [details]
experimental fontconfig file

on FC6, under zh_* locales, uses vector latin fonts for latin, and wqy for
9/10/11/12pt CJK char on-screen rendering; however, under en_*, wqy did not get
sufficient priority for CJK rendering.
Comment 2 Qianqian Fang 2007-05-28 03:42:41 EDT
This is a known "feature" of the font, designed mostly in the considerations for
Chinese users.

What I want to achieve with this current setup is:

when users specify a general font family class, such as Sans/Serif/Monospace,
WQY bitmap fonts are only preferred for displaying CJK glyphs at 9,10,11,12pt;
the CJK glyphs at other sizes will be rendered by installed vector CJK fonts on
the system; if no other CJK vector font exist, use WQY font instead (smaller
than 9pt will use 9pt, greater than 12pt will use 12pt).

when users specify "WenQuanYi bitmap Song" as font name, use this font for all
glyphs, no matter which size.

my test results with the current configuration on FC6 under en_US locale is
shown here (click the figure to enlarge):

http://wenq.org/gallery/displayimage.php?album=7&pos=11

in this case, the Latin were not overridden. 

However, I did notice, also reported by other users, under zh_CN/zh_TW/zh_SG,
the Latin characters for Sans/Serif/Mono were actually assigned to wqy bitmap
font. something like this

http://wenq.org/gallery/displayimage.php?album=7&pos=0

We think this is a "bug" of fontconfig, which seems not consistent for
lang-specific font selection, and giving fonts which covers the current locale
much higher priority than those do not. In this case, because wqy covers most
char. for zh_CN, so it overrides Dejavu/Bitstream Vera because they do not cover
these zones. 

Language/locale-specific font selection is an known issue for fontconfig, see
http://osdir.com/ml/fonts.fontconfig/2006-06/msg00007.html
and I know there are patches available, but not incorporated in the main branch. 

I came up with an experimental fontconfig file, see Attachment #155532 [details] 
(you need to override /etc/fonts/conf.d/85-wqy-bitmapsong.conf)

I found that under zh_* locale, this seems eliminates the above problem (tested
on FC6), however, under en_*, WQY fonts do not function at all for CJK
characters. I need more test to see the problem and decide if this works
consistently or just by chance. I would be glad to know the behavior of this
file on your system.

From the feedbacks from most Chinese user communities, I did not hear much
complain about this though. Most of them think it is worthwhile to keep this
font on the system for displaying CJK text; and in case they don't like wqy as
sans/serif, they will chose specific font to override sans/seif.
Comment 3 Kevin Kofler 2007-05-28 10:28:41 EDT
My locale is de_AT.UTF-8 and I did end up with overridden latin fonts. It's 
interesting that it apparently doesn't happen for you under en_US.
Comment 4 Qianqian Fang 2007-05-28 23:44:28 EDT
I ran a quick test on a FC6 virtual machine, under de locales, I found no
overbidding of Latin on this system, the screen shot for de_DE.UTF-8 is here: 

http://wenq.org/gallery/displayimage.php?album=7&pos=9

for de_AT.UTF-8, the screen is identical. the fontconfig is 2.4.1, the testing
page URL is

http://wqy.sourceforge.net/cgi-bin/index.cgi?WQYTest

I am curious what does this page look like on your system, and what's your
fontconfig version. Does other people have similar problem under non-zh locales?
Comment 5 Kevin Kofler 2008-01-26 06:56:13 EST

*** This bug has been marked as a duplicate of 381311 ***

Note You need to log in before you can comment on or make changes to this bug.