Bug 241564 - Icelandic keyboard layout wrong in Fedora 7 Test 4 (6.93).
Summary: Icelandic keyboard layout wrong in Fedora 7 Test 4 (6.93).
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xkeyboard-config   
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: bzcl34nup
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-28 07:23 UTC by David Bobroff
Modified: 2018-04-11 12:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 02:03:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 17786 None None None Never

Description David Bobroff 2007-05-28 07:23:16 UTC
Description of problem:
Icelandic keyboard layout is incorrect.

Version-Release number of selected component (if applicable):
Gnome-panel 2.18.0

How reproducible:
Switch to Icelandic keyboard (ISL) and type.

Steps to Reproduce:
1. Switch to Icelandic keyboard
2. type
3.
  
Actual results:

1234567890ö
qwertyuiopü+
asdfghjklöä#
<zxcvbnm,.þ

<shift>
°!"#$%&/()=Ö
ASDFGHJKLÖÄ´
>ZXCVBNM;:Þ

Expected results:

°1223456789ö-
qwertyuiopð-
<zxcvbnm,.þ

<shift>
̈!"#$%&/()=Ö_
QWERTYUIOPÐ?
ASDFGHJKLÆ*
>ZXCVBNM;:Þ

Additional info:

The key to the left of the numeral 1 should produce an umlaut/dierisis in the
shift mode.  In the above example it is putting this over the '!'.  The key just
to the left of the BACKSPACE key appears dead.  It should be the '-' and '_'
key.  The bottom row seems to be correct.

Not sure this is actually a Gnome Panel bug, but it is certainly a bug.

Comment 1 A S Alam 2007-05-28 07:42:01 UTC
as mention on list, bug should be 'devel'
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html 

Comment 3 Bug Zapper 2008-04-04 00:58:40 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 4 Jóhann B. Guðmundsson 2008-04-05 17:41:55 UTC
Tested against rawhide live iso 04.04 install

Gnome

°1234567890ö-
qwertyuiopð'
asdfghjklæ'+
<zxcvbnm,.þ

<shift>

¨!"#$%&/()=ö_
QWERTYUIOPÐ?
ASDFGHJKLÆÄ*
>ZXCVBNM;:Þ

Gnome terminal

°1234567890ö-
qwertyuiopð'
asdfghjklæ+'
<zxcvbnm,.þ

<shift>

¨!"#$%&/()=Ö_ 
QWERTYUIOPÐ? 
ASDFGHJKLÆÄ*
>ZXCVBNM;:Þ

Terminal

°1234567890ö-
qwertyuiopð'
asdfghjklæ'+
<zxcvbnm,.þ

<shift>

"!"#$%&/()=Ö_
ASDFGHJKLÆ^*
>ZXCVBNM;:Þ

There seems to still be something a miss here at least on Gnome side
these 2 characters differ from Gnome ( ¨ Ä ) and terminal ( " ^ )
And I think the "terminal" got it right ( " ^ ) vs Gnome getting it 
wrong.. We don't have or use Ä


Comment 5 Bug Zapper 2008-05-14 02:56:41 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Tony Fu 2008-09-10 03:13:16 UTC
requested by Jens Petersen (#27995)

Comment 7 Peter Hutterer 2008-09-26 08:51:00 UTC
Reported upstream https://bugs.freedesktop.org/show_bug.cgi?id=17786.

Comment 8 Fedora Update System 2008-09-28 23:55:31 UTC
xkeyboard-config-1.2-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xkeyboard-config-1.2-4.fc9

Comment 9 Fedora Update System 2008-10-01 06:43:33 UTC
xkeyboard-config-1.2-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xkeyboard-config'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8531

Comment 10 Fedora Update System 2008-10-16 02:03:24 UTC
xkeyboard-config-1.2-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.