Bug 241567 - RPM packages header bug
RPM packages header bug
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmdb-redhat (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-28 03:56 EDT by Felix Luk
Modified: 2013-01-09 20:38 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 08:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Luk 2007-05-28 03:56:56 EDT
Description of problem: When I run 'yum update' I get a list of dependency errors

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Run 'yum update'
2. Errors appear
3.
  
Actual results: Errors appear

Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gnomevfs
Error: Missing Dependency: gnome-python2-extras = 2.14.2-4.fc6 is needed by
package gnome-python2-libegg
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-canvas
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-bonobo
Error: Missing Dependency: yum = 3.0-6 is needed by package yum-updatesd

However when I search for the required packages (gnome-python2-2.16.0-1.fc6 and
yum-3.06) are installed on my computer. I think this is a bug with rpm package
headers but I could not find the "Fedora infrastructure" area to report.

Expected results: Update successful


Additional info:
Comment 1 Jesse Keating 2007-05-29 06:48:05 EDT
Is this an x86_64 machine?  Can you do "rpm -q gnome-python2.i386" and "rpm -q
gnome-python2.x86_64" ?
Comment 2 Felix Luk 2007-05-30 04:00:48 EDT
Yes, this is an AMD Athlon box, but I am running ia32 FC6 only.

The reply for "rpm -q gnome-python2.i386":
gnome-python2-2.16.0-1.fc6

The reply for "rpm -q gnome-python2.x86_64" is nothing
Comment 3 Jesse Keating 2007-05-30 09:07:21 EDT
Ok, so this isn't a multilib issue.  I'll look into this when I get into the office.
Comment 4 Jeff Johnson 2007-06-06 01:00:41 EDT
You can verify dependency closure (presumably what you mean
by rpm package headers) i.e. that all headers necessary to satisfy
dependencies are installed, by
    rpm -Va --nofiles
Comment 5 Felix Luk 2007-06-06 08:22:06 EDT
Okay, I have tried something else. Here's the output

-----------------------------------------------------
yum update yum
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for yum to pack into transaction set.
yum-3.0.6-1.fc6.noarch.rp 100% |=========================|  32 kB    00:00     
---> Package yum.noarch 0:3.0.6-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: yum = 3.0-6 for package: yum-updatesd
--> Finished Dependency Resolution
Error: Missing Dependency: yum = 3.0-6 is needed by package yum-updatesd
-----------------------------------------------------

When I tried updating yum the program won't let me because it thinks the *older*
package is required by another program.

It seems like the headers are a bit messed up
Comment 6 Jesse Keating 2007-06-06 11:19:26 EDT
What repo are you using, and what yum and yum-updatesd do you have installed?
Comment 7 Felix Luk 2007-06-11 08:34:26 EDT
Okay, I solved my problem. It turns out that there are two packages are both
installed, one older and one newer. Once I erased the newer version the system
updated correctly.

-----------------------------------------------
---> Package gnome-python2-bonobo.i386 0:2.16.2-2.fc6 set to be erased
---> Package gnome-python2-gnomevfs.i386 0:2.16.2-2.fc6 set to be erased
---> Package gnome-python2-libegg.i386 0:2.14.2-9.fc6 set to be erased
---> Package gnome-python2-canvas.i386 0:2.16.2-2.fc6 set to be erased
-----------------------------------------------

It's rather strange how that might happened.

Note You need to log in before you can comment on or make changes to this bug.