Bug 24157 - "Restart" and "Quit" - really RFE
"Restart" and "Quit" - really RFE
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-16 16:46 EST by Michal Jaegermann
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-17 11:10:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-01-16 16:46:40 EST
In /usr/share/sawfish/0.34/lisp/sawfish/wm/gnome/integration.jl
"Restart" and "Quit" menu entries are removed unconditionally.  Is there
any sane way to perform that action only when running a full Gnome
desktop?  A "pure sawfish" may be preferable when something more
lightweight is desired - on a laptop, for example - and these entries are
highly useful there.  Regretably my knowlegde of sawfish lisp interactions
is too superficial to propose a nice patch.

And yes, I did try to start sawfish by itself and these menu entries
are indeed gone.  Maybe GDMSESSION environment variable can be used
for the purpose?  Or maybe there are some better methods.

  Michal
  michal@harddata.com
Comment 1 Havoc Pennington 2001-07-12 15:34:59 EDT
I think any case where these options are useful would be a bug in the desktop
environment. When do you need them?

Most users don't care that there is a thing called "Sawfish," they just care
that there are window borders. ;-)
Comment 2 Michal Jaegermann 2001-07-12 18:58:51 EDT
> When do you need them?

I do not understand that comment.  I obviously need them when I want to
"Restart" (it happens from time to time that a window manager gets confused
and restarting it much preferable to loging out and login it - especially
if you have a long running processes) or "Quit".  In an absence of restart
re-logging is the only option.  It is also nice to be able to quit without
remembering "magic" key sequence when, for example, I am running "bare"
Sawfish manager on a laptop.  Why this is supposed to be "bug"?


> Most users don't care that there is a thing called "Sawfish,"

This comment trancends boundaries of my comprehension.  By the same token
most users do not care that there is a thing called "Gnome", or "KDE",
or whatever else.  Red Hat just happens to be using Sawfish as a default
window manager on a Gnome desktop.  What this has to do with this report????

The report simply asked not to make things gratituously harder for those
who do not follow "one-and-true" way.  Shrug!  May you never need restart.
Comment 3 Havoc Pennington 2001-07-12 22:11:36 EDT
Most users don't care about GNOME/KDE either. ;-) They find the whole thing
confusing.

Anyhow, the reason you give for restarting sawfish is that it may have bugs. If
so, then we fix those bugs. Would you add a restart button to a word processor?
Does any other app have a restart button? But any app can have bugs. Sawfish is
not unique in this respect. You only expect restart because traditionally some
WM's have had it. I think most often they had it because you had to restart to
reparse the config file. But Sawfish has no such issue, so restart is pointless.

For both quit and restart, you can always start the window manager capplet and
switch to twm and back or something.
Quit in particular is out of the question, for most users it's equivalent to a
"break my system badly" button and not something you want them to be able to click.
Comment 4 Michal Jaegermann 2001-07-12 22:57:41 EDT
> Anyhow, the reason you give for restarting sawfish is that it may have bugs.

Who says that these are sawfish bugs?  Maybe there are Netscape bugs or
whatever.  You never restarted fvwm or twm because some things stopped
updating properly?  I did.  So how about fixing these twm bugs for a start?
Through so many years this could be done many times over.

I am not worried about myself.  I can alway start 'sawfish-client' and
type there (restart).  No problemo!  I can also add (and I do) various
extra entries to different menus.  I know some folks for which this is
a black magic.

If I start a bare-bones sawfish then how do you propose I logout nicely?
You killed "Quit" menu.  Yes, you may put a "Logout" name on it if "Quit"
is grating your nerves.

Note You need to log in before you can comment on or make changes to this bug.