Bug 241587 - /etc/cron.daily/bugzilla fails
/etc/cron.daily/bugzilla fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-28 09:08 EDT by quackhacker
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-24 13:55:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description quackhacker 2007-05-28 09:08:26 EDT
Description of problem:
/etc/cron.daily/bugzilla fails, compilation aborted

Version-Release number of selected component (if applicable):
bugzilla-2.22.2-1.fc7

How reproducible: occurs every day when cron.daily runs


Steps to Reproduce:
1. /etc/cron.daily/bugzilla (is default on Fedora 6.93)
2. the default crontab for root user is sufficient
3.
  
Actual results:
Root receives email with following contents:

/etc/cron.daily/bugzilla:

No value for param user_verify_class (try running checksetup.pl again) at
Bugzilla/Config.pm line 191.
BEGIN failed--compilation aborted at Bugzilla/Auth.pm line 43.
Compilation failed in require at Bugzilla.pm line 28.
BEGIN failed--compilation aborted at Bugzilla.pm line 28.
Compilation failed in require at ./collectstats.pl line 42.
BEGIN failed--compilation aborted at ./collectstats.pl line 42.


Expected results:
not sure, since I don't recall running bugzilla from cron.daily before

Additional info:
Comment 1 quackhacker 2007-05-28 09:11:32 EDT
FWIW, when I ran checksetup.pl, I received this result:
/usr/share/bugzilla/checksetup.pl: line 128: use: command not found
/usr/share/bugzilla/checksetup.pl: line 130: BEGIN: command not found
/usr/share/bugzilla/checksetup.pl: line 131: syntax error near unexpected token `{'
/usr/share/bugzilla/checksetup.pl: line 131: `    if ($^O =~ /MSWin32/i) {'
Comment 2 John Berninger 2007-06-01 12:22:30 EDT
This package has been superceded by bugzilla-3.0-3.fc7.  The 3.0 package wasn't
in the test releases due to timing of when I was able to get it available for
FC6 and the CVS freeze.  Please upgrade to the latest version and let me know if
this issue persists.

Note You need to log in before you can comment on or make changes to this bug.