Bug 241594 - RHEL 4.6 feature request: ia64 getcpu system call support
Summary: RHEL 4.6 feature request: ia64 getcpu system call support
Status: CLOSED DUPLICATE of bug 241592
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-28 14:37 UTC by Luming Yu
Modified: 2013-08-06 01:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 16:28:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luming Yu 2007-05-28 14:37:14 UTC
Description of problem:

Recently Fenghua implemented getcpu system call for IPF that is

a clean interface to get the CPU and node number a process is running on.

There is  /proc/<pid>/stat, but that is not a well documented API that

can be used in production systems. Andi added a system call in x86-64 that 
does this




The implementation includes both sys_getcpu and fsys_getcpu.



sys_getcpu patch can be found at:

[PATCH] Hook up getcpu system call for IA64

ht tp://www.gelato.unsw.edu.au/archives/linux-ia64/0702/19940.html

fsys_getcpu patch can be found at:

[PATCH] fsys_getcpu for IA64

ht tp://www.gelato.unsw.edu.au/archives/linux-ia64/0702/19994.html
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Linda Wang 2007-08-20 16:28:14 UTC

*** This bug has been marked as a duplicate of 241592 ***


Note You need to log in before you can comment on or make changes to this bug.