Bug 2416 - lpd not restarting after a shutdown
lpd not restarting after a shutdown
Status: CLOSED DUPLICATE of bug 2368
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
5.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-29 12:43 EDT by jon
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-24 16:22:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jon 1999-04-29 12:43:31 EDT
I have several systems running 5.2 RH Linux on an Intel
platform and it seems that the systems which have remote
printers configured on them have problems bringin the lpd
services back online after a shutdown.

I have noticed several articles on this while searching the
FAQs but there does not seem to be a solution for it.

Here is what I find when I reboot one of these systems if i
go out and look for all the lpd processes I find the
current process and the previous process still hanging out
there. If I go into the /var/spool/lpd/ directory and more
out the lpd.lock file it still contains the old PID from
the previous boot. If i remove this file and kill all the
lpd processes and remove any hung print jobs and then
restart the lpd process and run <lpc restart> on the
printers it seems to be fine. I have hacked the lpd script
in /etc/rc.d/init.d and have it removing the lpd.lock file
when the system is shutdown and have it doing an extra
killproc on all lpd processes when the system starts back
up and this seemed to work on one clien's system but only
once.

I can be reached at 281-922-4222 ex 134 or email me at
jon@medsamerica.com

Thank you for your time!
Comment 1 Bill Nottingham 1999-05-24 16:22:59 EDT
*** This bug has been marked as a duplicate of 2368 ***

Note You need to log in before you can comment on or make changes to this bug.