Bug 241610 - Memory leak in current PAN version
Memory leak in current PAN version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pan (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Dalloz
Fedora Extras Quality Assurance
http://pan.rebelbase.com/download/rel...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-28 17:28 EDT by Jérôme Benoit
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.131-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 09:26:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jérôme Benoit 2007-05-28 17:28:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.10) Gecko/20070510 Fedora/1.5.0.10-6.fc6 Firefox/1.5.0.10

Description of problem:
PAN use 45% of the memory after one or two days of usage.

Version-Release number of selected component (if applicable):
pan-0.129-1.fc6

How reproducible:
Always


Steps to Reproduce:
1. Open PAN with some alt.binaries.* groups like .boneless
2. Use it normaly (post,download, etc.) during one or two days 
3. Open top in a terminal and sort process by % of memory usage

Actual Results:
PAN use 45% of memory ...
PAN is leaking heavily memory ...

Expected Results:
No memory leak.

Additional info:
The memory leak should have been plugged upstream, i've not yet verify it nor valgrind pan yet ...
Comment 1 Alexander Dalloz 2007-05-29 13:28:56 EDT
The problem is known upstream and was fixed with release 0.131 (440194 fix 0.127
memory leak (Charles)). Please see
http://pan.rebelbase.com/download/releases/0.131/.
As soon as F-7 is released and non-blocker updates are possible I will provide
an updated pan package. Not sooner to not break the upgrade path.
Comment 2 Jérôme Benoit 2007-06-04 07:00:41 EDT
Please provide an update, it's really a show stopper for pan user, F7 is out and
it's the same pan version, though leaking heavily memory ... Could you please
push an upgrade for F7 and FC6 extras ? 

(i'm running CVS version right now, but i'm thinking about beginners on fedora)

Thanks. 
Comment 3 Alexander Dalloz 2007-06-06 19:02:13 EDT
I can assure you that the update packages for F-7 and FC6 are on their way.
Please have a bit of patience. In the whole process I have to take care for a
sane upgrade path. So first F-7 updates-testing has to be passed and then, after
the stable update, the FC-6 update will appear soon after.
Comment 4 Fedora Update System 2007-06-07 11:57:45 EDT
pan-0.131-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Jérôme Benoit 2007-06-13 06:07:39 EDT
Hello,

So far this version do not leak heavily memory ... stable push time ? ;-)

Cheers.
Comment 6 Fedora Update System 2007-06-16 09:26:34 EDT
pan-0.131-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.