Bug 241628 - clamav-server-sysv is not usable after install
clamav-server-sysv is not usable after install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 01:03 EDT by Jerry Amundson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 21:38:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Amundson 2007-05-29 01:03:38 EDT
Description of problem:
Several flaws in clamav-server-sysv need correcting after installation for it to
be usable.

Version-Release number of selected component (if applicable):
clamav-server-sysv.i386                  0.88.7-2.fc6

How reproducible:
Always.

Steps to Reproduce:
1. yum install clamav-server-sysv
2.
3.
  
Actual results:
# chkconfig clamd-wrapper --add
service clamd-wrapper does not support chkconfig

Expected results:
# chkconfig clamd-wrapper --add
# chkconfig clamd-wrapper --list
clamd-wrapper   0:off   1:off   2:on    3:on    4:on    5:on    6:off


Additional info:
Why is there a depends in clamav-server for clamav-server-sysv? Seems it should
be the other way around...
Comment 1 Jerry Amundson 2007-05-29 01:06:06 EDT
Patch to give clamd-wrapper chkconfig support.
diff -Naur clamd-wrapper /usr/share/clamav/clamd-wrapper 
--- clamd-wrapper       2004-11-07 22:10:52.000000000 -0600
+++ /usr/share/clamav/clamd-wrapper     2007-05-28 23:56:23.000000000 -0500
@@ -1,7 +1,7 @@
 #!/bin/bash
 #
-# Xchkconfig: - 75 25
-# Xdescription: The clamd daemon listens for incoming connections on          \
+# chkconfig: - 75 25
+# description: The clamd daemon listens for incoming connections on           \
 #               Unix or TCP socket and scans files or directories on demand.
 
 test "$CLAMD_SERVICE" || {
Comment 2 Jerry Amundson 2007-05-29 01:12:25 EDT
... and make the script executable:
chmod u+x /usr/share/clamav/clamd-wrapper
Comment 3 Jerry Amundson 2007-05-29 01:16:51 EDT
... and with the "test" of an unset var as the first line, the script is
unusable anyway:
# service clamd-wrapper start
*** /etc/init.d/clamd-wrapper can not be called in this way
*** Please see /usr/share/doc/clamav-server-*/README how
*** the clamav-server can be configured
Comment 4 Enrico Scholz 2007-05-29 03:05:23 EDT
this is not intented to be executed; it provides functionality like
/etc/init.d/functions. See mentioned README for details.
Comment 5 Jerry Amundson 2007-05-29 09:03:21 EDT
In that case, please rename it to clamav-server-wrapper or something. As
compared to clamav-milter-sysv which *is* usable after install, and would *not*
have wasted my time ^*&#ing around with it before getting to a "README".

Also, /etc/init.d/functions is there because the system expects it to be there.
The same with halt and single. When I see any other script "foo" installed in
/etc/init.d, I expect "foo" to be a usable service. Period. Besides, the README
already covers copying clamd.int to /etc/init.d.

Lastly, what does this say about "usability", to have packages install that do
nothing but point to a README? I mean come on, I see you've made it flexible,
and that's fine, but why not install it with a pre-determined service running
from the start? Is this too much to ask?

Note You need to log in before you can comment on or make changes to this bug.