Bug 241640 - (CVE-2006-7205) CVE-2006-7205 php array_fill memory consumption
CVE-2006-7205 php array_fill memory consumption
Status: CLOSED NOTABUG
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 05:54 EDT by Joe Orton
Modified: 2007-05-29 06:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-29 06:03:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2007-05-29 05:54:44 EDT
Description of problem:
The array_fill function in ext/standard/array.c in PHP 4.4.2 and 5.1.2 allows
context-dependent attackers to cause a denial of service (memory consumption)
via a large num value.

http://www.infigo.hr/hr/in_focus/advisories/INFIGO-2006-04-02
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2006-7205
Comment 1 Joe Orton 2007-05-29 06:03:54 EDT
The memory_limit configuration option is used to constrain the amount of memory
which a script can consume during execution.  If this setting is disabled (or
set unreasonably high), it is expected behaviour that scripts will be able to
consume large amounts of memory during script execution.

The memory_limit setting is enabled by default in all versions of PHP
distributed in Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.