Bug 241667 - --noipv6 option for network is ignored
--noipv6 option for network is ignored
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Installation_Guide (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ruediger Landmann
Michael Hideo
: Documentation
Depends On:
Blocks: 237606
  Show dependency treegraph
 
Reported: 2007-05-29 10:09 EDT by Klaus Ethgen
Modified: 2009-08-03 02:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 02:14:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Ethgen 2007-05-29 10:09:39 EDT
The option
 network --bootproto=dhcp --device=eth0 --noipv6 --onboot=yes

in the kickstart file nevertheless use ipv6 as well as for the installation 
(dhcp on ipv6 is tried first and ipv4 is used only as fallback) and for the 
final system.
Comment 1 Paul Nasrat 2007-05-29 10:26:53 EDT
Anaconda is a two stage installer - where is the ks file - on physical media or
on the network. If it's on the network kicked off with pxelinux or something
then you haven't told the first stage not to use ipv6.

Also Red Hat Enterprise Linux issues should first be directed to Red Hat Support
as on the bugzilla.redhat.com home page:

If you are a Red Hat Enterprise Linux customer and have an active support
entitlement, please log in to Red Hat Support
https://www.redhat.com/apps/support/  for assistance with your issue.

Filing through support ensures the appropriate prioritisation and process for
Red Hat Enterprise Linux update releases.
Comment 2 Klaus Ethgen 2007-05-29 15:15:06 EDT
> Anaconda is a two stage installer - where is the ks file - on physical media
> or on the network. If it's on the network kicked off with pxelinux or
> something then you haven't told the first stage not to use ipv6.

This is correct, I only set the option in the kickstart file. In fact we use a 
kickstart file taken over nfs when the computer is started over a PXE 
environment.

But there is nothing in the documentation that such a option is needed by a 
first stage. The normal understanding is that this option just do what is 
written in the documentation; switching of the ipv6 support (I can understand 
if the ipv6 is only disabled in the final installation but not that this option 
is completely ignored).

> Also Red Hat Enterprise Linux issues should first be directed to Red Hat
> Support as on the bugzilla.redhat.com home page:
> 
> If you are a Red Hat Enterprise Linux customer and have an active support
> entitlement, please log in to Red Hat Support
> https://www.redhat.com/apps/support/  for assistance with your issue.

Yes I understand. But unfortunate we have a bit difficult support situation in 
the ETH Zürich. We have a own satellite with a site wide license. But We have 
unfortunate only limited access to the official support. That's the reason I 
fill the bug only here. But I will try to enforce it to the official support. 
In past they told us that we have to register a bug first on bugzilla and later 
send the report number to our responsible.
Comment 3 Paul Nasrat 2007-05-29 15:48:48 EDT
Please clarify the use of network options and pxe/netbooting in the installation
guide.
Comment 4 Don Domingo 2007-05-29 19:14:41 EDT
reassigning to jwulf@redhat.com for processing
Comment 5 Klaus Ethgen 2007-05-30 09:17:38 EDT
#3: The systems boot over PXE and receive the parameter from DHCP. Then in 
pxelinux is loaded from tftp. pxelinux is starting the installation with the 
parameter "APPEND text ks=nfs:xxxx:/xxxx/xxxx/kickstart/ ksdevice=eth0 
ramdisk_size=8192 initrd=initrd-redhat-ws5-32 noshell autostep nofallback".

Then the installation is done by a kickstart with the snippet above.
Comment 6 Klaus Ethgen 2007-05-31 06:37:17 EDT
A small note:
The documentation also write that you have to use "--noipv6=..." but anaconda 
doesn't work if you specify any value to --noipv6
Comment 7 Michael Hideo 2007-10-22 22:46:09 EDT
Removing automation notification
Comment 8 Michael Hideo 2008-01-21 23:36:25 EST
Moving to Don
Comment 9 Ruediger Landmann 2009-08-03 02:14:00 EDT
Thanks Klaus, I've added a warning about this scenario to the Guide; it will become visible next time that we republish the document.

Note You need to log in before you can comment on or make changes to this bug.