Bug 24171 - group utmp does not exist
Summary: group utmp does not exist
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-17 00:46 UTC by Jeremy Katz
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 23:12:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2001-01-17 00:46:34 UTC
gnome-libs needs to preinstall utempter so that the utmp group will exist
when gnome-libs is installed

Comment 1 Jeremy Katz 2001-01-17 00:47:43 UTC
sorry, beta2 with gnome-libs-1.2.8-1

Comment 2 Glen Foster 2001-01-17 18:19:10 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 3 Nalin Dahyabhai 2001-01-22 18:24:44 UTC
The utmp group is created by the initscripts %pre scriptlet, so adding a Prereq:
on initscripts should take care of this.

Comment 4 Elliot Lee 2001-02-01 23:12:13 UTC
utempter also creates the utmp group, and is less likely to have extraneous
depdendencies, so it probably makes more sense to depend on it.

Comment 5 Elliot Lee 2001-02-07 21:17:28 UTC
Fixed in gnome-libs-1.2.8-6 by adding the utempter dependency.

Comment 6 Mike A. Harris 2006-07-28 05:06:49 UTC
The spec also contains the following comment:
# Added to avoid the warning messages about utmp group, bug #24171
# fixme, just libzvt?

zvt doesn't appear to be in libgnome, or in Fedora for that matter.  A
complete grep of libgnome, vte shows no sign of utempter usage.

Since we're replacing the Red Hat utempter with the alternative
implementation named 'libutempter' in FC6, while updating the packages
that depend on utempter I noticed this.

Since I can't be easily sure wether or not a dependency still exists,
I thought I'd mention it here.  It is possible the dependency might
be able to be removed now, but I'll leave that to the discretion of
the package maintainer.



Note You need to log in before you can comment on or make changes to this bug.