Bug 241725 - OOPS: reading non-root config file
Summary: OOPS: reading non-root config file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vsftpd   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Martin Nagy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-29 20:49 UTC by Jim Beasley
Modified: 2016-07-26 23:46 UTC (History)
3 users (show)

Fixed In Version: vsftpd-2.0.1-5.EL4.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 19:37:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Beasley 2007-05-29 20:49:34 UTC
Description of problem:
when specifying the 'user_config_dir' directive in vsftpd.conf, vsftpd will fail
when there is no user config file in the specified directory.  Please see
bug#232404 (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=232404)

Version-Release number of selected component (if applicable):
vsftpd-2.0.1-5.EL4.5

How reproducible:


Steps to Reproduce:
1. install vsftpd
2. add line to vsftpd.conf: user_config_dir=/etc/vsftpd/user_conf
3. login as a local or anonymous user without creating a config file for the user
  
Actual results:
500 OOPS: reading non-root config file

Expected results:
should be able to login even when user config file for a specific user doesn't 
exist (i.e. user config files should not be mandatory for all users when enabled)

Additional info:
touch a file in user_config_dir with the name of the ftp user to workaround this
issue

Comment 1 Maros Barabas 2007-06-20 13:54:12 UTC
Please try it with vsftpd-2.0.1-5.EL4.5. Works for me. Thanks

Comment 2 Martin Nagy 2008-01-30 19:37:10 UTC
Closing as this bug is already fixed.


Note You need to log in before you can comment on or make changes to this bug.